meta.yaml.template 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. {% set version = "3.41.2" %}
  2. {% set build = "0" %}
  3. {% set year = "2023" %}
  4. {% set version_split = version.split(".") %}
  5. {% set major = version_split[0] %}
  6. {% set minor = version_split[1]|int * 10 %}
  7. {% set bugfix = version_split[2]|int * 100 %}
  8. {% set version_coded=(major ~ (("%03d" % minor)|string) ~ (("%03d" % bugfix)|string)) %}
  9. package:
  10. name: sqlite
  11. version: {{ version }}
  12. source:
  13. url: https://www.sqlite.org/{{ year }}/sqlite-autoconf-{{ version_coded }}.tar.gz
  14. sha256: e98c100dd1da4e30fa460761dab7c0b91a50b785e167f8c57acc46514fae9499
  15. patches:
  16. - expose_symbols.patch # [win]
  17. build:
  18. number: {{ build }}
  19. run_exports:
  20. # sometimes adds new symbols. Default behavior is OK.
  21. # https://abi-laboratory.pro/tracker/timeline/sqlite/
  22. - {{ pin_subpackage('sqlite') }}
  23. requirements:
  24. build:
  25. - {{ compiler('c') }}
  26. - make # [not win]
  27. - libtool # [not win]
  28. - m2-patch # [win]
  29. host:
  30. - ncurses 6.4 # [not win]
  31. - readline 8.0 # [not ((linux and aarch64) or (osx and arm64) or win)]
  32. - readline 8.1 # [(linux and aarch64) or (osx and arm64)]
  33. - zlib 1.2 # [not win]
  34. run:
  35. - {{ pin_compatible('ncurses') }} # [not win]
  36. - {{ pin_compatible('readline') }} # [not win]
  37. - {{ pin_compatible('zlib') }} # [not win]
  38. test:
  39. commands:
  40. - sqlite3 --version
  41. - if not exist %PREFIX%\\Library\bin\sqlite3.dll exit 1 # [win]
  42. - if not exist %PREFIX%\\Library\lib\sqlite3.lib exit 1 # [win]
  43. - test -f $PREFIX/lib/libsqlite3${SHLIB_EXT} # [not win]
  44. - test ! -f $PREFIX/lib/libsqlite3.a # [not win]
  45. - if not exist %PREFIX%\\Library\include\sqlite3.h exit 1 # [win]
  46. - if not exist %PREFIX%\\Library\include\sqlite3ext.h exit 1 # [win]
  47. - test -f $PREFIX/include/sqlite3.h # [not win]
  48. - test -f $PREFIX/include/sqlite3ext.h # [not win]
  49. about:
  50. home: https://www.sqlite.org/
  51. license: blessing
  52. license_file: LICENSE.md
  53. license_family: Other
  54. summary: Implements a self-contained, zero-configuration, SQL database engine
  55. description: |
  56. SQLite is a self-contained, high-reliability, embedded, full-featured,
  57. public-domain, SQL database engine. It is the most used database engine
  58. in the world.
  59. doc_url: https://www.sqlite.org/docs.html
  60. dev_url: https://sqlite.org/src/dir?ci=trunk
  61. extra:
  62. recipe-maintainers:
  63. - jakirkham
  64. - jjhelmus
  65. - msarahan
  66. - ocefpaf
  67. - snorfalorpagus
  68. - mingwandroid
  69. - xylar