meta.yaml.template 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. {% set name = "zstd" %}
  2. {% set version = "1.5.5" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://github.com/facebook/{{ name }}/archive/v{{ version }}.tar.gz
  8. sha256: 98e9c3d949d1b924e28e01eccb7deed865eefebf25c2f21c702e5cd5b63b85e1
  9. build:
  10. number: 0
  11. skip: True # [win and vc<14]
  12. run_exports:
  13. # pretty bad removal of symbols in every other micro release:
  14. # https://abi-laboratory.pro/tracker/timeline/zstd/
  15. # Working smoothly since 1.4.x
  16. - {{ pin_subpackage('zstd', max_pin='x.x') }}
  17. requirements:
  18. build:
  19. - {{ compiler('c') }}
  20. - {{ compiler('cxx') }}
  21. - msinttypes # [win]
  22. - ninja
  23. - make # [unix]
  24. # Require `cmake-no-system` to break circular dependency;
  25. # the `cmake` package on defaults requires `zstd`.
  26. - cmake-no-system
  27. host:
  28. - zlib
  29. - lz4-c
  30. - xz
  31. test:
  32. requires:
  33. - pkg-config # [unix]
  34. commands:
  35. - zstd -be -i5
  36. - test -f ${PREFIX}/include/{{ name }}.h # [unix]
  37. - test -f ${PREFIX}/lib/lib{{ name }}.a # [unix]
  38. - test -f ${PREFIX}/lib/lib{{ name }}.so # [linux]
  39. - test -f ${PREFIX}/lib/lib{{ name }}.dylib # [osx]
  40. - if not exist %LIBRARY_INC%\{{ name }}.h exit 1 # [win]
  41. - if not exist %LIBRARY_BIN%\lib{{ name }}.dll exit 1 # [win]
  42. - if not exist %LIBRARY_LIB%\lib{{ name }}.lib exit 1 # [win]
  43. - if not exist %LIBRARY_LIB%\lib{{ name }}_static.lib exit 1 # [win and vc>=14]
  44. - export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig # [unix]
  45. - test -f ${PREFIX}/lib/pkgconfig/lib{{ name }}.pc # [unix]
  46. - pkg-config --cflags lib{{ name }} # [unix]
  47. about:
  48. home: https://facebook.github.io/zstd/
  49. license: BSD-3-Clause AND GPL-2.0-or-later
  50. license_family: BSD
  51. license_file: LICENSE
  52. summary: "Zstandard - Fast real-time compression algorithm"
  53. description: |
  54. Zstandard is a real-time compression algorithm, providing high compression
  55. ratios. It offers a very wide range of compression / speed trade-off, while
  56. being backed by a very fast decoder. It also offers a special mode for
  57. small data, called dictionary compression, and can create dictionaries from
  58. any sample set. Zstandard library is provided as open source software using
  59. a BSD license.
  60. doc_url: https://facebook.github.io/zstd/zstd_manual.html
  61. dev_url: https://github.com/facebook/zstd
  62. extra:
  63. recipe-maintainers:
  64. - rmax
  65. - msarahan
  66. - xhochy
  67. - chenghlee