meta.yaml.template 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. {% set name = "zstandard" %}
  2. {% set version = "0.19.0" %}
  3. package:
  4. name: {{ name }}
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
  8. sha256: 31d12fcd942dd8dbf52ca5f6b1bbe287f44e5d551a081a983ff3ea2082867863
  9. build:
  10. number: 0
  11. skip: True # [py<36]
  12. requirements:
  13. build:
  14. - {{ compiler('c') }}
  15. host:
  16. - python
  17. - cffi 1.15
  18. - pip
  19. - setuptools
  20. - wheel
  21. run:
  22. - python
  23. - cffi >=1.11
  24. test:
  25. requires:
  26. - pip
  27. commands:
  28. - pip check
  29. imports:
  30. - zstandard
  31. about:
  32. home: https://github.com/indygreg/python-zstandard
  33. license: BSD-3-Clause
  34. license_family: BSD
  35. license_file:
  36. - LICENSE
  37. - zstd/LICENSE
  38. summary: Zstandard bindings for Python
  39. description: |
  40. This project provides Python bindings for interfacing with the
  41. Zstandard compression library. A C extension and CFFI interface are
  42. provided.
  43. doc_url: https://github.com/indygreg/python-zstandard/blob/main/README.rst#python-zstandard
  44. dev_url: https://github.com/indygreg/python-zstandard
  45. extra:
  46. recipe-maintainers:
  47. - rmax
  48. - xhochy