meta.yaml.template 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. {% set version = "1.2.13" %}
  2. package:
  3. name: zlib
  4. version: {{ version }}
  5. source:
  6. url: http://zlib.net/zlib-{{ version }}.tar.gz
  7. sha256: b3a24de97a8fdbc835b9833169501030b8977031bcb54b3b3ac13740f846ab30
  8. patches:
  9. - cmake-pkg-config.patch
  10. # Both patches are needed to remediate CVE-2022-37434; the "-1" patch
  11. # had a bug that broke downstream packages like `curl`, which was
  12. # addressed in the "-2" patch. As of 2022-09-07, these patches have
  13. # been adopted by Debian and SUSE as fixes for the vulnerability.
  14. # We're following Debian's pattern and keeping these patches separate
  15. # (rather than consolidating them) to keep their provenance clear.
  16. # - CVE-2022-37434-1.patch (extremly suspicious patch ... )
  17. # - CVE-2022-37434-2.patch
  18. build:
  19. number: 0
  20. run_exports:
  21. # mostly OK, but some scary symbol removal. Let's try for trusting them.
  22. # https://abi-laboratory.pro/tracker/timeline/zlib/
  23. - {{ pin_subpackage('zlib', max_pin='x.x') }}
  24. requirements:
  25. build:
  26. - {{ compiler('c') }}
  27. - {{ compiler('cxx') }} # [win32]
  28. # Require `cmake-no-system` to break circular dependency;
  29. # the `cmake` package on defaults requires `zstd`.
  30. - cmake-no-system
  31. - msinttypes # [win and vc<14]
  32. - make # [not win]
  33. - patch # [not win]
  34. - m2-patch # [win]
  35. host:
  36. - ripgrep # Should this be removed?
  37. test:
  38. commands:
  39. - test -f ${PREFIX}/include/zlib.h # [unix]
  40. - test -f ${PREFIX}/lib/libz.a # [unix]
  41. - test -f ${PREFIX}/lib/libz.so # [linux]
  42. - test -f ${PREFIX}/lib/libz.dylib # [osx]
  43. - if not exist %PREFIX%/Library/include/zlib.h exit 1 # [win]
  44. - if not exist %PREFIX%/Library/lib/z.lib exit 1 # [win]
  45. - if not exist %PREFIX%/Library/lib/zdll.lib exit 1 # [win]
  46. - if not exist %PREFIX%/Library/lib/zlib.lib exit 1 # [win]
  47. - if not exist %PREFIX%/Library/lib/zlibstatic.lib exit 1 # [win]
  48. - if not exist %PREFIX%/Library/bin/zlib.dll exit 1 # [win]
  49. about:
  50. home: https://zlib.net/
  51. # http://zlib.net/zlib_license.html
  52. license: Zlib
  53. summary: Massively spiffy yet delicately unobtrusive compression library
  54. license_family: Other
  55. # Note: we copy 'recipe/license.txt' which contains the header from `zlib.h`.
  56. # Correct update of this recipe requires an update of `recipe/license.txt`.
  57. license_file: zlib.h
  58. description: |
  59. zlib is designed to be a free, general-purpose, lossless data-compression
  60. library for use on virtually any computer hardware and operating system.
  61. doc_url: https://zlib.net/manual.html
  62. dev_url: https://github.com/madler/zlib
  63. extra:
  64. recipe-maintainers:
  65. - groutr
  66. - msarahan
  67. - ocefpaf
  68. - mingwandroid