meta.yaml.template 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. {% set version = "5.4.2" %}
  2. package:
  3. name: xz
  4. version: {{ version }}
  5. source:
  6. url: https://sourceforge.net/projects/lzmautils/files/xz-{{ version }}.tar.bz2
  7. sha256: aa49909cbd9028c4666a35fa4975f9a6203ed98154fbb8223ee43ef9ceee97c3
  8. build:
  9. number: 0
  10. run_exports:
  11. # XZ's track record of backcompat is very good. Keep default pins (next major version)
  12. # https://abi-laboratory.pro/tracker/timeline/xz/
  13. - {{ pin_subpackage('xz') }}
  14. requirements:
  15. build:
  16. - {{ compiler('c') }}
  17. - m2w64-toolchain # [win]
  18. - posix # [win]
  19. - make # [not win]
  20. - automake # [not win]
  21. - libtool # [not win]
  22. host:
  23. - msinttypes # [win and vc<14]
  24. test:
  25. requires:
  26. # To use 'conda inspect', install conda-build
  27. - conda-build # [not win]
  28. commands:
  29. - xz --help # [not win]
  30. - unxz --help # [not win]
  31. - lzma --help # [not win]
  32. - xz.exe --help # [win]
  33. - unxz.exe --help # [win]
  34. - if not exist %PREFIX%\\Library\\bin\\liblzma.dll exit 1 # [win]
  35. - if not exist %PREFIX%\\Library\\lib\\liblzma.lib exit 1 # [win]
  36. - if not exist %PREFIX%\\Library\\lib\\liblzma_static.lib exit 1 # [win]
  37. - if not exist %PREFIX%\\Library\\include\\lzma.h exit 1 # [win]
  38. - if not exist %PREFIX%\\Library\\bin\\xz.exe exit 1 # [win]
  39. - if exist %PREFIX%\\lib exit 1 # [win]
  40. - conda inspect linkages -p $PREFIX $PKG_NAME # [not win]
  41. - conda inspect objects -p $PREFIX $PKG_NAME # [osx]
  42. about:
  43. home: https://tukaani.org/xz/
  44. license: LGPL-2.1-or-later and GPL-2.0-or-later
  45. license_file: COPYING
  46. license_family: GPL2
  47. summary: Data compression software with high compression ratio
  48. description: |
  49. XZ Utils is free general-purpose data compression software with a high
  50. compression ratio. XZ Utils were written for POSIX-like systems, but also
  51. work on some not-so-POSIX systems.
  52. doc_url: https://tukaani.org/xz/
  53. dev_url: https://git.tukaani.org/
  54. extra:
  55. recipe-maintainers:
  56. - msarahan
  57. - ocefpaf
  58. - mingwandroid
  59. - nehaljwani
  60. - scopatz