meta.yaml.template 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. {% set name = "wheel" %}
  2. {% set version = "0.38.4" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
  8. sha256: 965f5259b566725405b05e7cf774052044b1ed30119b5d586b2703aafe8719ac
  9. build:
  10. number: 0
  11. skip: True # [py<37]
  12. script: python setup.py install --single-version-externally-managed --record=record.txt
  13. entry_points:
  14. - wheel = wheel.cli:main
  15. requirements:
  16. host:
  17. - python
  18. - setuptools
  19. # pip has not to be present in the host section
  20. run:
  21. - python
  22. test:
  23. imports:
  24. - wheel
  25. - wheel.cli
  26. - wheel.vendored
  27. - wheel.vendored.packaging
  28. requires:
  29. - pip
  30. commands:
  31. - pip check
  32. - wheel --help
  33. - wheel version
  34. about:
  35. home: https://github.com/pypa/wheel
  36. license: MIT
  37. license_family: MIT
  38. license_file: LICENSE.txt
  39. summary: A built-package format for Python.
  40. description: |
  41. This library is the reference implementation of the Python wheel packaging standard,
  42. as defined in PEP 427.
  43. It has two different roles:
  44. 1. A setuptools extension for building wheels that provides the bdist_wheel setuptools command
  45. 2. A command line tool for working with wheel files
  46. dev_url: https://github.com/pypa/wheel
  47. doc_url: https://wheel.readthedocs.io/
  48. extra:
  49. recipe-maintainers:
  50. - jakirkham
  51. - pelson
  52. - ocefpaf
  53. - mingwandroid
  54. skip-lints:
  55. - uses_setup_py
  56. - missing_wheel