meta.yaml 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # This file created by conda-build 3.22.0
  2. # meta.yaml template originally from:
  3. # /feedstock/recipe, last modified Fri Feb 17 08:16:53 2023
  4. # ------------------------------------------------
  5. package:
  6. name: wheel
  7. version: 0.38.4
  8. source:
  9. sha256: 965f5259b566725405b05e7cf774052044b1ed30119b5d586b2703aafe8719ac
  10. url: https://pypi.io/packages/source/w/wheel/wheel-0.38.4.tar.gz
  11. build:
  12. entry_points:
  13. - wheel = wheel.cli:main
  14. number: '0'
  15. script: python setup.py install --single-version-externally-managed --record=record.txt
  16. string: py39h06a4308_0
  17. requirements:
  18. host:
  19. - _libgcc_mutex 0.1 main
  20. - _openmp_mutex 5.1 1_gnu
  21. - ca-certificates 2023.01.10 h06a4308_0
  22. - certifi 2022.12.7 py39h06a4308_0
  23. - ld_impl_linux-64 2.38 h1181459_1
  24. - libffi 3.4.2 h6a678d5_6
  25. - libgcc-ng 11.2.0 h1234567_1
  26. - libgomp 11.2.0 h1234567_1
  27. - libstdcxx-ng 11.2.0 h1234567_1
  28. - ncurses 6.4 h6a678d5_0
  29. - openssl 1.1.1t h7f8727e_0
  30. - python 3.9.16 h7a1cb2a_0
  31. - readline 8.2 h5eee18b_0
  32. - setuptools 65.6.3 py39h06a4308_0
  33. - sqlite 3.40.1 h5082296_0
  34. - tk 8.6.12 h1ccaba5_0
  35. - tzdata 2022g h04d1e81_0
  36. - xz 5.2.10 h5eee18b_1
  37. - zlib 1.2.13 h5eee18b_0
  38. run:
  39. - python >=3.9,<3.10.0a0
  40. test:
  41. commands:
  42. - pip check
  43. - wheel --help
  44. - wheel version
  45. imports:
  46. - wheel
  47. - wheel.cli
  48. - wheel.vendored
  49. - wheel.vendored.packaging
  50. requires:
  51. - pip
  52. about:
  53. description: "This library is the reference implementation of the Python wheel packaging\
  54. \ standard,\nas defined in PEP 427.\nIt has two different roles:\n 1. A setuptools\
  55. \ extension for building wheels that provides the bdist_wheel setuptools command\n\
  56. \ 2. A command line tool for working with wheel files\n"
  57. dev_url: https://github.com/pypa/wheel
  58. doc_url: https://wheel.readthedocs.io/
  59. home: https://github.com/pypa/wheel
  60. license: MIT
  61. license_family: MIT
  62. license_file: LICENSE.txt
  63. summary: A built-package format for Python.
  64. extra:
  65. copy_test_source_files: true
  66. final: true
  67. flow_run_id: 56789633-2906-440c-aa73-05244944220a
  68. recipe-maintainers:
  69. - jakirkham
  70. - mingwandroid
  71. - ocefpaf
  72. - pelson
  73. remote_url: git@github.com:AnacondaRecipes/wheel-feedstock.git
  74. sha: 3a6887d038d3c92954c0adff1039216772e1fd18
  75. skip-lints:
  76. - missing_wheel
  77. - uses_setup_py