meta.yaml.template 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. {% set name = "urllib3" %}
  2. {% set version = "1.26.16" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
  8. sha256: 8f135f6502756bde6b2a9b28989df5fbe87c9970cecaa69041edcce7f0589b14
  9. build:
  10. number: 0
  11. skip: True # [py<36]
  12. script: {{ PYTHON }} -m pip install . --no-deps --no-build-isolation -vv
  13. requirements:
  14. host:
  15. - python
  16. - pip
  17. - setuptools
  18. - wheel
  19. run:
  20. - python
  21. # optional deps [secure]
  22. - pyopenssl >=0.14
  23. - cryptography >=1.3.4
  24. - idna >=2.0.0
  25. - certifi
  26. # optional deps [socks]
  27. - pysocks >=1.5.6,<2.0,!=1.5.7
  28. # optional deps [brotli]
  29. # issue with brotli and brotlicffi, so revert to brotlipy
  30. # https://github.com/AnacondaRecipes/urllib3-feedstock/issues/2
  31. - brotlipy >=0.6.0
  32. test:
  33. imports:
  34. - urllib3
  35. - urllib3.contrib
  36. - urllib3.contrib._securetransport
  37. - urllib3.packages
  38. - urllib3.packages.backports
  39. - urllib3.util
  40. commands:
  41. - pip check
  42. requires:
  43. - pip
  44. about:
  45. home: https://urllib3.readthedocs.io/
  46. license: MIT
  47. license_family: MIT
  48. license_file: LICENSE.txt
  49. summary: HTTP library with thread-safe connection pooling, file post, and more.
  50. description: |
  51. urllib3 is a powerful, sanity-friendly HTTP client for Python. Much of the
  52. Python ecosystem already uses urllib3. urllib3 brings many critical features
  53. that are missing from the Python standard libraries, such as thread safety,
  54. connection pooling, client side ssl/tls verification, support for gzip and
  55. deflate encodings, HTTP and SOCKS proxy support, helpers for retrying requests
  56. and dealing with HTTP redirects.
  57. doc_url: https://urllib3.readthedocs.io/
  58. dev_url: https://github.com/urllib3/urllib3
  59. extra:
  60. recipe-maintainers:
  61. - pmlandwehr
  62. - sigmavirus24
  63. - ocefpaf
  64. - sethmlarson