meta.yaml.template 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. {% set version = "4.65.0" %}
  2. package:
  3. name: tqdm
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/t/tqdm/tqdm-{{ version }}.tar.gz
  7. sha256: 1871fb68a86b8fb3b59ca4cdd3dcccbc7e6d613eeed31f4c332531977b89beb5
  8. build:
  9. number: 0
  10. script: {{ PYTHON }} -m pip install . --no-deps -vv
  11. entry_points:
  12. - tqdm = tqdm.cli:main
  13. requirements:
  14. host:
  15. - python
  16. - pip
  17. - setuptools_scm
  18. - setuptools
  19. - toml
  20. - wheel
  21. run:
  22. - python
  23. - colorama # [win]
  24. run_constrained:
  25. - slack-sdk
  26. - requests
  27. - ipywidgets >=6
  28. test:
  29. requires:
  30. - dask
  31. - keras
  32. - numpy
  33. - pip
  34. - pytest
  35. - pytest-timeout
  36. - pytest-asyncio
  37. - rich
  38. - ripgrep
  39. source_files:
  40. - tests
  41. - setup.cfg
  42. - pyproject.toml
  43. imports:
  44. - tqdm
  45. commands:
  46. - pip check
  47. - tqdm --help
  48. - tqdm -v | rg {{ version }}
  49. - pytest -k "not tests_perf"
  50. about:
  51. home: https://tqdm.github.io/
  52. license: MPL-2.0 AND MIT
  53. license_family: MOZILLA
  54. license_file: LICENCE
  55. summary: A Fast, Extensible Progress Meter
  56. dev_url: https://github.com/tqdm/tqdm
  57. doc_url: https://tqdm.github.io/
  58. extra:
  59. recipe-maintainers:
  60. - casperdcl
  61. - pmlandwehr