meta.yaml.template 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. {% set name = "toolz" %}
  2. {% set version = "0.12.0" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/toolz-{{ version }}.tar.gz
  8. sha256: 88c570861c440ee3f2f6037c4654613228ff40c93a6c25e0eba70d17282c6194
  9. build:
  10. number: 0
  11. skip: True # [py<35]
  12. script: {{ PYTHON }} -m pip install . -vv
  13. requirements:
  14. host:
  15. - python
  16. - pip
  17. - setuptools
  18. - wheel
  19. run:
  20. - python
  21. test:
  22. imports:
  23. - tlz
  24. - toolz
  25. - toolz.curried
  26. - toolz.functoolz
  27. - toolz.sandbox
  28. requires:
  29. - pip
  30. - pytest
  31. commands:
  32. - pip check
  33. - pytest --doctest-modules --pyargs toolz
  34. about:
  35. home: https://toolz.readthedocs.io/
  36. license: BSD-3-Clause
  37. license_family: BSD
  38. license_file: LICENSE.txt
  39. license_url: https://github.com/pytoolz/toolz/blob/master/LICENSE.txt
  40. summary: List processing tools and functional utilities
  41. description: |
  42. Toolz provides a set of utility functions for iterators, functions, and
  43. dictionaries. These functions interoperate well and form the building
  44. blocks of common data analytic operations. They extend the standard
  45. libraries itertools and functools and borrow heavily from the standard
  46. libraries of contemporary functional languages.
  47. doc_url: https://toolz.readthedocs.io/
  48. doc_source_url: https://github.com/pytoolz/toolz/blob/master/doc/source/index.rst
  49. dev_url: https://github.com/pytoolz/toolz
  50. extra:
  51. recipe-maintainers:
  52. - mrocklin
  53. - eriknw
  54. - jcrist
  55. - jakirkham
  56. - ocefpaf