meta.yaml.template 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. {% set version = "1.16.0" %}
  2. package:
  3. name: six
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/s/six/six-{{ version }}.tar.gz
  7. sha256: 1e61c37477a1626458e36f7b1d82aa5c9b094fa4802892072e49de9c60c4c926
  8. build:
  9. number: 1
  10. noarch: python
  11. script: {{ PYTHON }} -m pip install . -vv
  12. requirements:
  13. host:
  14. - python
  15. - pip
  16. - wheel
  17. - setuptools
  18. run:
  19. - python
  20. test:
  21. imports:
  22. - six
  23. commands:
  24. - pip check
  25. requires:
  26. - pip
  27. about:
  28. home: https://six.readthedocs.io/
  29. license: MIT
  30. license_family: MIT
  31. license_file: LICENSE
  32. summary: Python 2 and 3 compatibility utilities
  33. description: |
  34. Six provides simple utilities for wrapping over differences between
  35. Python 2 and Python 3. It is intended to support codebases that work on
  36. both Python 2 and 3 without modification. six consists of only one Python
  37. file, so it is painless to copy into a project.
  38. doc_url: https://six.readthedocs.io/
  39. dev_url: https://github.com/benjaminp/six
  40. doc_src_url: https://github.com/benjaminp/six/tree/master/documentation
  41. extra:
  42. recipe-maintainers:
  43. - jakirkham
  44. - msarahan
  45. - ocefpaf