meta.yaml 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # This file created by conda-build 3.21.7
  2. # meta.yaml template originally from:
  3. # /tmp/build/80754af9/rsync-recipes/six-1.16.0-on-linux_64, last modified Mon Feb 14 21:52:29 2022
  4. # ------------------------------------------------
  5. package:
  6. name: six
  7. version: 1.16.0
  8. source:
  9. sha256: 1e61c37477a1626458e36f7b1d82aa5c9b094fa4802892072e49de9c60c4c926
  10. url: https://pypi.io/packages/source/s/six/six-1.16.0.tar.gz
  11. build:
  12. noarch: python
  13. number: '1'
  14. script: /tmp/build/80754af9/six_1644875935023/_h_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_/bin/python
  15. -m pip install . -vv
  16. string: pyhd3eb1b0_1
  17. requirements:
  18. host:
  19. - _libgcc_mutex 0.1 main
  20. - _openmp_mutex 4.5 1_gnu
  21. - bzip2 1.0.8 h7b6447c_0
  22. - ca-certificates 2021.10.26 h06a4308_2
  23. - certifi 2021.5.30 py310h06a4308_0
  24. - ld_impl_linux-64 2.35.1 h7274673_9
  25. - libffi 3.3 he6710b0_2
  26. - libgcc-ng 9.3.0 h5101ec6_17
  27. - libgomp 9.3.0 h5101ec6_17
  28. - libstdcxx-ng 9.3.0 hd4cf53a_17
  29. - libuuid 1.0.3 h7f8727e_2
  30. - ncurses 6.3 h7f8727e_2
  31. - openssl 1.1.1m h7f8727e_0
  32. - pip 21.2.4 py310h06a4308_0
  33. - python 3.10.0 h12debd9_4
  34. - readline 8.1.2 h7f8727e_1
  35. - setuptools 58.0.4 py310h06a4308_0
  36. - sqlite 3.37.2 hc218d9a_0
  37. - tk 8.6.11 h1ccaba5_0
  38. - tzdata 2021e hda174b7_0
  39. - wheel 0.37.1 pyhd3eb1b0_0
  40. - xz 5.2.5 h7b6447c_0
  41. - zlib 1.2.11 h7f8727e_4
  42. run:
  43. - python
  44. test:
  45. commands:
  46. - pip check
  47. imports:
  48. - six
  49. requires:
  50. - pip
  51. about:
  52. description: 'Six provides simple utilities for wrapping over differences between
  53. Python 2 and Python 3. It is intended to support codebases that work on
  54. both Python 2 and 3 without modification. six consists of only one Python
  55. file, so it is painless to copy into a project.
  56. '
  57. dev_url: https://github.com/benjaminp/six
  58. doc_src_url: https://github.com/benjaminp/six/tree/master/documentation
  59. doc_url: https://six.readthedocs.io/
  60. home: https://six.readthedocs.io/
  61. license: MIT
  62. license_family: MIT
  63. license_file: LICENSE
  64. summary: Python 2 and 3 compatibility utilities
  65. extra:
  66. copy_test_source_files: true
  67. final: true
  68. recipe-maintainers:
  69. - jakirkham
  70. - msarahan
  71. - ocefpaf