meta.yaml.template 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. {% set name = "setuptools" %}
  2. {% set version = "67.8.0" %}
  3. {% set build = "0" %}
  4. {% set checksum = "62642358adc77ffa87233bc4d2354c4b2682d214048f500964dbe760ccedf102" %}
  5. # make sure to set CONDA_ADD_PIP_AS_PYTHON_DEPENDENCY=0 environ-variable before building it
  6. package:
  7. name: {{ name }}
  8. version: {{ version }}
  9. source:
  10. url: https://pypi.io/packages/source/s/setuptools/setuptools-{{ version }}.tar.gz
  11. sha256: {{ checksum }}
  12. patches:
  13. # Modify setuptools to fail if used in conda build (encourage people to add all deps in meta.yaml).
  14. - patches/0002-disable-downloads-inside-conda-build.patch
  15. # distutils patches from python-feedstock
  16. - patches/0021-Add-d1trimfile-SRC_DIR-to-make-pdbs-more-relocatable.patch
  17. build:
  18. number: 0
  19. skip: True # [py<37]
  20. requirements:
  21. build:
  22. - patch # [unix]
  23. - m2-patch # [win]
  24. host:
  25. # omitting wheel for this package to avoid cyclic dependencies
  26. - python
  27. run:
  28. - python
  29. test:
  30. requires:
  31. - pip
  32. commands:
  33. - pip check
  34. imports:
  35. - setuptools
  36. - pkg_resources
  37. - distutils
  38. about:
  39. home: https://github.com/pypa/setuptools
  40. license: MIT
  41. license_file: LICENSE
  42. license_family: MIT
  43. summary: Download, build, install, upgrade, and uninstall Python packages
  44. description: |
  45. Setuptools is a fully-featured, actively-maintained, and stable library
  46. designed to facilitate packaging Python projects.
  47. doc_url: https://setuptools.pypa.io/en/latest/
  48. dev_url: https://github.com/pypa/setuptools
  49. extra:
  50. recipe-maintainers:
  51. - jakirkham
  52. - msarahan
  53. - ocefpaf
  54. - nicoddemus
  55. - isuruf