meta.yaml.template 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. {% set version = "0.2.6" %}
  2. package:
  3. name: ruamel.yaml.clib
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/r/ruamel.yaml.clib/ruamel.yaml.clib-{{ version }}.tar.gz
  7. sha256: 4ff604ce439abb20794f05613c374759ce10e3595d1867764dd1ae675b85acbd
  8. build:
  9. number: 1
  10. script: {{ PYTHON }} -m pip install . -vv
  11. skip: True # [py<35]
  12. ignore_run_exports:
  13. - python
  14. requirements:
  15. build:
  16. - {{ compiler('c') }}
  17. host:
  18. - python
  19. - pip
  20. - setuptools
  21. - wheel
  22. run:
  23. - python
  24. test:
  25. requires:
  26. - pip
  27. - ruamel.yaml
  28. commands:
  29. - pip check
  30. imports:
  31. - _ruamel_yaml
  32. about:
  33. home: https://sourceforge.net/projects/ruamel-yaml-clib/
  34. license: MIT
  35. license_family: MIT
  36. license_file: LICENSE
  37. license_url: https://sourceforge.net/p/ruamel-yaml-clib/code/ci/{{ version }}/tree/LICENSE
  38. summary: C version of reader, parser and emitter for ruamel.yaml derived from libyaml
  39. description: |
  40. This package was split of from ruamel.yaml, so that ruamel.yaml can be build as a universal wheel.
  41. Apart from the C code seldom changing, and taking a long time to compile for all platforms, this allows
  42. installation of the .so on Linux systems under /usr/lib64/pythonX.Y (without a .pth file or a ruamel
  43. directory) and the Python code for ruamel.yaml under /usr/lib/pythonX.Y.
  44. doc_url: https://yaml.readthedocs.io
  45. doc_source_url: https://sourceforge.net/p/ruamel-yaml-clib/code/ci/{{ version }}/tree/_doc/
  46. dev_url: https://sourceforge.net/projects/ruamel-yaml-clib/
  47. extra:
  48. recipe-maintainers:
  49. - ocefpaf