meta.yaml.template 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. {% set name = "ruamel.yaml" %}
  2. {% set version = "0.17.21" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/ruamel.yaml-{{ version }}.tar.gz
  8. sha256: 8b7ce697a2f212752a35c1ac414471dc16c424c9573be4926b56ff3f5d23b7af
  9. build:
  10. number: 0
  11. skip: true # [py<35]
  12. script: {{ PYTHON }} -m pip install . --no-deps -vv
  13. requirements:
  14. build:
  15. - {{ compiler('c') }}
  16. host:
  17. - python
  18. - pip
  19. - ruamel
  20. - setuptools
  21. - wheel
  22. run:
  23. - python
  24. # Even though upstream lists this optional,
  25. # importing ruamel.yaml fails without the cli
  26. - ruamel.yaml.clib >=0.2.6 # [py<311]
  27. test:
  28. imports:
  29. - ruamel.yaml
  30. requires:
  31. - pip
  32. commands:
  33. - pip check
  34. about:
  35. home: https://sourceforge.net/projects/ruamel-yaml/
  36. license: MIT
  37. license_family: MIT
  38. license_file: LICENSE
  39. license_url: https://sourceforge.net/p/ruamel-yaml/code/ci/{{ version }}/tree/LICENSE
  40. summary: "A YAML package for Python. It is a derivative of Kirill Simonov's PyYAML 3.11 which supports YAML1.1"
  41. description: "A YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order"
  42. doc_url: https://yaml.readthedocs.io
  43. doc_source_url: https://sourceforge.net/p/ruamel-yaml/code/ci/{{ version }}/tree/_doc/
  44. dev_url: https://sourceforge.net/projects/ruamel-yaml/
  45. extra:
  46. recipe-maintainers:
  47. - jakirkham
  48. - pelson
  49. - mwcraig
  50. - ocefpaf
  51. - mbargull