meta.yaml.template 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. {% set name = "requests" %}
  2. {% set version = "2.29.0" %}
  3. {% set hash = "f2e34a75f4749019bb0e3effb66683630e4ffeaf75819fb51bebef1bf5aef059" %}
  4. {% set build_number = "0" %}
  5. package:
  6. name: {{ name|lower }}
  7. version: {{ version }}
  8. source:
  9. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/requests-{{ version }}.tar.gz
  10. sha256: {{ hash }}
  11. build:
  12. number: {{ build_number }}
  13. script: {{ PYTHON }} -m pip install . -vv --no-deps --no-build-isolation
  14. skip: True # [py<37]
  15. requirements:
  16. host:
  17. - python
  18. - pip
  19. - setuptools
  20. - wheel
  21. run:
  22. - python
  23. - certifi >=2017.4.17
  24. - charset-normalizer >=2,<4
  25. - idna >=2.5,<4
  26. - urllib3 >=1.21.1,<1.27
  27. # https://github.com/psf/requests/blob/da9996fe4dc63356e9467d0a5e10df3d89a8528e/requests/__init__.py#L103-L115
  28. run_constrained:
  29. - chardet >=3.0.2,<6
  30. test:
  31. requires:
  32. - pip
  33. - conda
  34. commands:
  35. - pip check
  36. # to make sure this doesn't break conda at the very least
  37. - conda create -v --dry-run -n requests-test numpy
  38. imports:
  39. - requests
  40. about:
  41. home: https://requests.readthedocs.io/en/latest/
  42. license: Apache-2.0
  43. license_family: Apache
  44. license_file: LICENSE
  45. summary: Requests is an elegant and simple HTTP library for Python, built with ♥.
  46. description: |
  47. Requests is the only Non-GMO HTTP library for Python, safe for human
  48. consumption.
  49. doc_url: https://requests.readthedocs.io/en/latest/
  50. dev_url: https://github.com/psf/requests
  51. extra:
  52. recipe-maintainers:
  53. - jakirkham
  54. - kalefranz
  55. - mcg1969
  56. - mingwandroid
  57. - msarahan
  58. - pelson
  59. - sigmavirus24
  60. - ocefpaf
  61. - carlodri