meta.yaml.template 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. {% set version = "8.2" %}
  2. package:
  3. name: readline
  4. version: {{ version }}
  5. source:
  6. url: https://ftp.gnu.org/gnu/readline/readline-{{ version }}.tar.gz
  7. sha256: 3feb7171f16a84ee82ca18a36d7b9be109a52c04f492a053331d7d1095007c35
  8. build:
  9. # Per the upstream homepage, Windows is not supported.
  10. # To avoid build failure Windows is therefore skipped.
  11. skip: true # [win]
  12. number: 0
  13. run_exports:
  14. # change soname at major ver: https://abi-laboratory.pro/tracker/timeline/readline/
  15. - {{ pin_subpackage('readline') }}
  16. requirements:
  17. build:
  18. - pkg-config
  19. - {{ compiler('c') }}
  20. - make
  21. host:
  22. - ncurses
  23. test:
  24. requires:
  25. - python 3.*
  26. commands:
  27. {% set readline_libs = [
  28. 'libreadline',
  29. 'libhistory'
  30. ] %}
  31. {% for lib in readline_libs %}
  32. - test -f ${PREFIX}/lib/{{ lib }}.a
  33. - test -f ${PREFIX}/lib/{{ lib }}${SHLIB_EXT} # [not win]
  34. {% endfor %}
  35. # catch missing termcap/ncurses linkage problems
  36. - python -c "import readline"
  37. about:
  38. home: https://tiswww.case.edu/php/chet/readline/rltop.html
  39. license: GPL-3.0-only
  40. license_family: GPL
  41. license_file: COPYING
  42. license_url: https://tiswww.case.edu/php/chet/readline/README
  43. summary: library for editing command lines as they are typed in
  44. description: |
  45. The GNU Readline library provides a set of functions for use by applications
  46. that allow users to edit command lines as they are typed in.
  47. The Readline library includes additional functions to maintain a list of previously-entered command lines,
  48. to recall and perhaps reedit those lines, and perform csh-like history expansion on previous commands.
  49. dev_url: https://git.savannah.gnu.org/cgit/readline.git/
  50. doc_url: https://tiswww.case.edu/php/chet/readline/rltop.html
  51. extra:
  52. recipe-maintainers:
  53. - croth1
  54. - jakirkham
  55. - jjhelmus
  56. - pelson
  57. - msarahan
  58. - asmeurer
  59. - msarahan
  60. - mingwandroid
  61. - ocefpaf