meta.yaml.template 838 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. {% set version = "1.7.1" %}
  2. package:
  3. name: pysocks
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/P/PySocks/PySocks-{{ version }}.tar.gz
  7. sha256: 3f8804571ebe159c380ac6de37643bb4685970655d3bba243530d6558b799aa0
  8. build:
  9. number: 0
  10. script: "{{ PYTHON }} -m pip install . --no-deps -vv"
  11. requirements:
  12. host:
  13. - python
  14. - pip
  15. run:
  16. - python
  17. - win_inet_pton # [win]
  18. test:
  19. imports:
  20. - socks
  21. about:
  22. home: https://github.com/Anorov/PySocks
  23. license_file: LICENSE
  24. license: BSD 3-Clause
  25. summary: 'A Python SOCKS client module. See https://github.com/Anorov/PySocks for more information.'
  26. license_family: BSD
  27. doc_url: https://github.com/Anorov/PySocks/blob/master/README.md
  28. dev_url: https://github.com/Anorov/PySocks
  29. extra:
  30. recipe-maintainers:
  31. - pmlandwehr
  32. - ocefpaf