meta.yaml.template 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. {% set name = "pyopenssl" %}
  2. {% set version = "23.0.0" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/pyOpenSSL-{{ version }}.tar.gz
  8. sha256: c1cc5f86bcacefc84dada7d31175cae1b1518d5f60d3d0bb595a67822a868a6f
  9. build:
  10. number: 0
  11. skip: true # [py<36]
  12. script: {{ PYTHON }} -m pip install . -vv --no-deps
  13. requirements:
  14. host:
  15. - python
  16. - pip
  17. - setuptools
  18. - wheel
  19. run:
  20. - python
  21. - cryptography >=38.0.0,<40
  22. test:
  23. imports:
  24. - OpenSSL
  25. - OpenSSL.crypto
  26. - OpenSSL.rand
  27. - OpenSSL.SSL
  28. requires:
  29. - pip
  30. commands:
  31. - pip check
  32. - python -m OpenSSL.debug
  33. about:
  34. home: https://github.com/pyca/pyopenssl
  35. license: Apache-2.0
  36. license_family: Apache
  37. license_file: LICENSE
  38. summary: Python wrapper module around the OpenSSL library
  39. description: |
  40. pyOpenSSL is a high-level wrapper around a subset of the OpenSSL library.
  41. It includes:
  42. -SSL.Connection objects, wrapping the methods of Python's portable sockets
  43. -Callbacks written in Python
  44. -Extensive error-handling mechanism, mirroring OpenSSL's error codes
  45. and much more.
  46. doc_url: https://pyopenssl.readthedocs.org/en/stable/
  47. dev_url: https://github.com/pyca/pyopenssl
  48. extra:
  49. recipe-maintainers:
  50. - goanpeca
  51. - nehaljwani
  52. - mingwandroid