1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859 |
- {% set name = "pyopenssl" %}
- {% set version = "23.0.0" %}
- package:
- name: {{ name|lower }}
- version: {{ version }}
- source:
- url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/pyOpenSSL-{{ version }}.tar.gz
- sha256: c1cc5f86bcacefc84dada7d31175cae1b1518d5f60d3d0bb595a67822a868a6f
- build:
- number: 0
- skip: true # [py<36]
- script: {{ PYTHON }} -m pip install . -vv --no-deps
- requirements:
- host:
- - python
- - pip
- - setuptools
- - wheel
- run:
- - python
- - cryptography >=38.0.0,<40
- test:
- imports:
- - OpenSSL
- - OpenSSL.crypto
- - OpenSSL.rand
- - OpenSSL.SSL
- requires:
- - pip
- commands:
- - pip check
- - python -m OpenSSL.debug
- about:
- home: https://github.com/pyca/pyopenssl
- license: Apache-2.0
- license_family: Apache
- license_file: LICENSE
- summary: Python wrapper module around the OpenSSL library
- description: |
- pyOpenSSL is a high-level wrapper around a subset of the OpenSSL library.
- It includes:
- -SSL.Connection objects, wrapping the methods of Python's portable sockets
- -Callbacks written in Python
- -Extensive error-handling mechanism, mirroring OpenSSL's error codes
- and much more.
- doc_url: https://pyopenssl.readthedocs.org/en/stable/
- dev_url: https://github.com/pyca/pyopenssl
- extra:
- recipe-maintainers:
- - goanpeca
- - nehaljwani
- - mingwandroid
|