meta.yaml.template 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. {% set name = "pycparser" %}
  2. {% set version = "2.21" %}
  3. {% set sha256 = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206" %}
  4. package:
  5. name: {{ name|lower }}
  6. version: {{ version }}
  7. source:
  8. fn: {{ name }}-{{ version }}.tar.gz
  9. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
  10. sha256: {{ sha256 }}
  11. build:
  12. noarch: python
  13. number: 0
  14. skip: True # [py<36]
  15. script: {{ PYTHON }} -m pip install . -vvv
  16. requirements:
  17. host:
  18. - pip
  19. - python
  20. - setuptools
  21. - wheel
  22. run:
  23. - python >=3.6
  24. test:
  25. imports:
  26. - pycparser
  27. - pycparser.ply
  28. requires:
  29. - pip
  30. - python <3.10
  31. commands:
  32. - pip check
  33. about:
  34. home: https://github.com/eliben/pycparser
  35. license: BSD-3-clause
  36. license_family: BSD
  37. license_file: LICENSE
  38. summary: Complete C99 parser in pure Python
  39. description: |
  40. pycparser is a complete parser of the C language, written in pure Python using the PLY parsing library.
  41. It parses C code into an AST and can serve as a front-end for C compilers or analysis tools.
  42. dev_url: https://github.com/eliben/pycparser
  43. doc_url: https://github.com/eliben/pycparser/blob/master/README.rst
  44. extra:
  45. recipe-maintainers:
  46. - synapticarbors