meta.yaml 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # This file created by conda-build 3.21.5
  2. # meta.yaml template originally from:
  3. # /tmp/build/80754af9/combined_recipe, last modified Wed Nov 10 10:49:01 2021
  4. # ------------------------------------------------
  5. package:
  6. name: pycparser
  7. version: '2.21'
  8. source:
  9. fn: pycparser-2.21.tar.gz
  10. sha256: e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206
  11. url: https://pypi.io/packages/source/p/pycparser/pycparser-2.21.tar.gz
  12. build:
  13. noarch: python
  14. number: '0'
  15. script: /tmp/build/80754af9/pycparser_1636541352034/_h_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_plac/bin/python
  16. -m pip install . -vvv
  17. string: pyhd3eb1b0_0
  18. requirements:
  19. host:
  20. - _libgcc_mutex 0.1 main
  21. - _openmp_mutex 4.5 1_gnu
  22. - ca-certificates 2021.10.26 h06a4308_2
  23. - certifi 2021.10.8 py39h06a4308_0
  24. - ld_impl_linux-64 2.35.1 h7274673_9
  25. - libffi 3.3 he6710b0_2
  26. - libgcc-ng 9.3.0 h5101ec6_17
  27. - libgomp 9.3.0 h5101ec6_17
  28. - libstdcxx-ng 9.3.0 hd4cf53a_17
  29. - ncurses 6.3 heee7806_1
  30. - openssl 1.1.1l h7f8727e_0
  31. - pip 21.2.4 py39h06a4308_0
  32. - python 3.9.7 h12debd9_1
  33. - readline 8.1 h27cfd23_0
  34. - setuptools 58.0.4 py39h06a4308_0
  35. - sqlite 3.36.0 hc218d9a_0
  36. - tk 8.6.11 h1ccaba5_0
  37. - tzdata 2021e hda174b7_0
  38. - wheel 0.37.0 pyhd3eb1b0_1
  39. - xz 5.2.5 h7b6447c_0
  40. - zlib 1.2.11 h7b6447c_3
  41. run:
  42. - python >=3.6
  43. test:
  44. commands:
  45. - pip check
  46. imports:
  47. - pycparser
  48. - pycparser.ply
  49. requires:
  50. - pip
  51. - python <3.10
  52. about:
  53. description: 'pycparser is a complete parser of the C language, written in pure
  54. Python using the PLY parsing library.
  55. It parses C code into an AST and can serve as a front-end for C compilers or analysis
  56. tools.
  57. '
  58. dev_url: https://github.com/eliben/pycparser
  59. doc_url: https://github.com/eliben/pycparser/blob/master/README.rst
  60. home: https://github.com/eliben/pycparser
  61. license: BSD-3-clause
  62. license_family: BSD
  63. license_file: LICENSE
  64. summary: Complete C99 parser in pure Python
  65. extra:
  66. copy_test_source_files: true
  67. final: true
  68. recipe-maintainers:
  69. - synapticarbors