123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172 |
- # This file created by conda-build 3.21.5
- # meta.yaml template originally from:
- # /tmp/build/80754af9/combined_recipe, last modified Wed Nov 10 10:49:01 2021
- # ------------------------------------------------
- package:
- name: pycparser
- version: '2.21'
- source:
- fn: pycparser-2.21.tar.gz
- sha256: e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206
- url: https://pypi.io/packages/source/p/pycparser/pycparser-2.21.tar.gz
- build:
- noarch: python
- number: '0'
- script: /tmp/build/80754af9/pycparser_1636541352034/_h_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_plac/bin/python
- -m pip install . -vvv
- string: pyhd3eb1b0_0
- requirements:
- host:
- - _libgcc_mutex 0.1 main
- - _openmp_mutex 4.5 1_gnu
- - ca-certificates 2021.10.26 h06a4308_2
- - certifi 2021.10.8 py39h06a4308_0
- - ld_impl_linux-64 2.35.1 h7274673_9
- - libffi 3.3 he6710b0_2
- - libgcc-ng 9.3.0 h5101ec6_17
- - libgomp 9.3.0 h5101ec6_17
- - libstdcxx-ng 9.3.0 hd4cf53a_17
- - ncurses 6.3 heee7806_1
- - openssl 1.1.1l h7f8727e_0
- - pip 21.2.4 py39h06a4308_0
- - python 3.9.7 h12debd9_1
- - readline 8.1 h27cfd23_0
- - setuptools 58.0.4 py39h06a4308_0
- - sqlite 3.36.0 hc218d9a_0
- - tk 8.6.11 h1ccaba5_0
- - tzdata 2021e hda174b7_0
- - wheel 0.37.0 pyhd3eb1b0_1
- - xz 5.2.5 h7b6447c_0
- - zlib 1.2.11 h7b6447c_3
- run:
- - python >=3.6
- test:
- commands:
- - pip check
- imports:
- - pycparser
- - pycparser.ply
- requires:
- - pip
- - python <3.10
- about:
- description: 'pycparser is a complete parser of the C language, written in pure
- Python using the PLY parsing library.
- It parses C code into an AST and can serve as a front-end for C compilers or analysis
- tools.
- '
- dev_url: https://github.com/eliben/pycparser
- doc_url: https://github.com/eliben/pycparser/blob/master/README.rst
- home: https://github.com/eliben/pycparser
- license: BSD-3-clause
- license_family: BSD
- license_file: LICENSE
- summary: Complete C99 parser in pure Python
- extra:
- copy_test_source_files: true
- final: true
- recipe-maintainers:
- - synapticarbors
|