meta.yaml.template 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. {% set name = "pycosat" %}
  2. {% set version = "0.6.4" %}
  3. package:
  4. name: {{ name }}
  5. version: {{ version }}
  6. source:
  7. url: https://github.com/conda/{{ name }}/archive/{{ version }}.tar.gz
  8. sha256: 79ffa99156810e58876dd6374af0b7bff88f9a4580ca8b8468c414c5c2454bb8
  9. build:
  10. number: 0
  11. script: {{ PYTHON }} -m pip install . --no-deps -vv
  12. requirements:
  13. build:
  14. - python # [build_platform != target_platform]
  15. - cross-python_{{ target_platform }} # [build_platform != target_platform]
  16. - {{ compiler('c') }}
  17. - pip
  18. - setuptools
  19. - wheel
  20. host:
  21. - msinttypes # [win and py2k]
  22. - python
  23. - pip
  24. run:
  25. - python
  26. test:
  27. files:
  28. - qg3-08.cnf
  29. - uf20-098.cnf
  30. - sudoku.py
  31. - test_package.py
  32. requires:
  33. - pip
  34. imports:
  35. - pycosat
  36. commands:
  37. - pip check
  38. - python test_package.py "{{ version }}"
  39. about:
  40. home: https://github.com/conda/pycosat
  41. license: MIT
  42. license_family: MIT
  43. license_file:
  44. - LICENSE
  45. license_url: https://github.com/conda/pycosat/blob/{{ version }}/LICENSE
  46. summary: Bindings to picosat (a SAT solver)
  47. description: |
  48. PicoSAT is a popular SAT solver written by Armin Biere in pure C. This
  49. package provides efficient Python bindings to picosat on the C level, i.e.
  50. when importing pycosat, the picosat solver becomes part of the Python
  51. process itself.
  52. doc_url: https://pypi.org/project/pycosat/
  53. doc_source_url: https://github.com/conda/pycosat/blob/master/README.rst
  54. dev_url: https://github.com/conda/pycosat
  55. extra:
  56. recipe-maintainers:
  57. - jakirkham
  58. - kalefranz
  59. - mcg1969
  60. - msarahan
  61. - pelson
  62. - nehaljwani
  63. - mingwandroid