meta.yaml 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. # This file created by conda-build 3.22.0
  2. # meta.yaml template originally from:
  3. # /feedstock/recipe, last modified Wed Oct 26 17:31:38 2022
  4. # ------------------------------------------------
  5. package:
  6. name: pycosat
  7. version: 0.6.4
  8. source:
  9. sha256: 79ffa99156810e58876dd6374af0b7bff88f9a4580ca8b8468c414c5c2454bb8
  10. url: https://github.com/conda/pycosat/archive/0.6.4.tar.gz
  11. build:
  12. number: '0'
  13. script: /croot/pycosat_1666805502580/_h_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold/bin/python
  14. -m pip install . --no-deps -vv
  15. string: py39h5eee18b_0
  16. requirements:
  17. build:
  18. - _libgcc_mutex 0.1 main
  19. - _openmp_mutex 5.1 1_gnu
  20. - _sysroot_linux-64_curr_repodata_hack 3 haa98f57_10
  21. - binutils_impl_linux-64 2.38 h2a08ee3_1
  22. - binutils_linux-64 2.38.0 hc2dff05_0
  23. - bzip2 1.0.8 h7b6447c_0
  24. - ca-certificates 2022.07.19 h06a4308_0
  25. - certifi 2022.9.24 py310h06a4308_0
  26. - gcc_impl_linux-64 11.2.0 h1234567_1
  27. - gcc_linux-64 11.2.0 h5c386dc_0
  28. - kernel-headers_linux-64 3.10.0 h57e8cba_10
  29. - ld_impl_linux-64 2.38 h1181459_1
  30. - libffi 3.3 he6710b0_2
  31. - libgcc-devel_linux-64 11.2.0 h1234567_1
  32. - libgcc-ng 11.2.0 h1234567_1
  33. - libgomp 11.2.0 h1234567_1
  34. - libstdcxx-ng 11.2.0 h1234567_1
  35. - libuuid 1.0.3 h7f8727e_2
  36. - ncurses 6.3 h5eee18b_3
  37. - openssl 1.1.1q h7f8727e_0
  38. - pip 22.2.2 py310h06a4308_0
  39. - python 3.10.6 haa1d7c7_1
  40. - readline 8.2 h5eee18b_0
  41. - setuptools 63.4.1 py310h06a4308_0
  42. - sqlite 3.39.3 h5082296_0
  43. - sysroot_linux-64 2.17 h57e8cba_10
  44. - tk 8.6.12 h1ccaba5_0
  45. - tzdata 2022e h04d1e81_0
  46. - wheel 0.37.1 pyhd3eb1b0_0
  47. - xz 5.2.6 h5eee18b_0
  48. - zlib 1.2.13 h5eee18b_0
  49. host:
  50. - _libgcc_mutex 0.1 main
  51. - _openmp_mutex 5.1 1_gnu
  52. - ca-certificates 2022.07.19 h06a4308_0
  53. - certifi 2022.9.24 py39h06a4308_0
  54. - ld_impl_linux-64 2.38 h1181459_1
  55. - libffi 3.3 he6710b0_2
  56. - libgcc-ng 11.2.0 h1234567_1
  57. - libgomp 11.2.0 h1234567_1
  58. - libstdcxx-ng 11.2.0 h1234567_1
  59. - ncurses 6.3 h5eee18b_3
  60. - openssl 1.1.1q h7f8727e_0
  61. - pip 22.2.2 py39h06a4308_0
  62. - python 3.9.13 haa1d7c7_2
  63. - readline 8.2 h5eee18b_0
  64. - setuptools 63.4.1 py39h06a4308_0
  65. - sqlite 3.39.3 h5082296_0
  66. - tk 8.6.12 h1ccaba5_0
  67. - tzdata 2022e h04d1e81_0
  68. - wheel 0.37.1 pyhd3eb1b0_0
  69. - xz 5.2.6 h5eee18b_0
  70. - zlib 1.2.13 h5eee18b_0
  71. run:
  72. - libgcc-ng >=11.2.0
  73. - python >=3.9,<3.10.0a0
  74. test:
  75. commands:
  76. - pip check
  77. - python test_package.py "0.6.4"
  78. files:
  79. - qg3-08.cnf
  80. - sudoku.py
  81. - test_package.py
  82. - uf20-098.cnf
  83. imports:
  84. - pycosat
  85. requires:
  86. - pip
  87. about:
  88. description: 'PicoSAT is a popular SAT solver written by Armin Biere in pure C.
  89. This
  90. package provides efficient Python bindings to picosat on the C level, i.e.
  91. when importing pycosat, the picosat solver becomes part of the Python
  92. process itself.
  93. '
  94. dev_url: https://github.com/conda/pycosat
  95. doc_source_url: https://github.com/conda/pycosat/blob/master/README.rst
  96. doc_url: https://pypi.org/project/pycosat/
  97. home: https://github.com/conda/pycosat
  98. license: MIT
  99. license_family: MIT
  100. license_file:
  101. - LICENSE
  102. license_url: https://github.com/conda/pycosat/blob/0.6.4/LICENSE
  103. summary: Bindings to picosat (a SAT solver)
  104. extra:
  105. copy_test_source_files: true
  106. final: true
  107. flow_run_id: 31bb377e-4f5a-48d3-893a-3135cd08bdaf
  108. recipe-maintainers:
  109. - jakirkham
  110. - kalefranz
  111. - mcg1969
  112. - mingwandroid
  113. - msarahan
  114. - nehaljwani
  115. - pelson
  116. remote_url: git@github.com:AnacondaRecipes/pycosat-feedstock.git
  117. sha: 18eedcf1f31f03a7e1ac629331f92a182cb57adb