meta.yaml.template 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. {% set name = "pluggy" %}
  2. {% set version = "1.0.0" %}
  3. {% set sha256 = "4224373bacce55f955a878bf9cfa763c1e360858e330072059e10bad68531159" %}
  4. package:
  5. name: {{ name }}
  6. version: {{ version }}
  7. source:
  8. fn: {{ name }}-{{ version }}.tar.gz
  9. url: https://pypi.io/packages/source/{{ name [0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
  10. sha256: {{ sha256 }}
  11. build:
  12. number: 1
  13. skip: True # [py<36]
  14. script: python -m pip install . --no-deps --ignore-installed
  15. requirements:
  16. host:
  17. - python
  18. - pip
  19. - setuptools
  20. - setuptools_scm
  21. - wheel
  22. run:
  23. - python
  24. - importlib_metadata >=0.12 # [py<38]
  25. test:
  26. imports:
  27. - pluggy
  28. requires:
  29. - pip
  30. command:
  31. - pip check
  32. about:
  33. home: https://github.com/pytest-dev/pluggy
  34. license: MIT
  35. license_family: MIT
  36. license_file: LICENSE
  37. summary: 'Plugin registration and hook calling for Python'
  38. doc_url: https://pluggy.readthedocs.io/en/latest/
  39. dev_url: https://github.com/pytest-dev/pluggy/
  40. extra:
  41. recipe-maintainers:
  42. - JohnGreeley
  43. - nicoddemus