1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253 |
- {% set version = "23.1.2" %}
- # make sure to set CONDA_ADD_PIP_AS_PYTHON_DEPENDENCY=0 environ-variable before building it
- package:
- name: pip
- version: {{ version }}
- source:
- url: https://pypi.io/packages/source/p/pip/pip-{{ version }}.tar.gz
- sha256: 0e7c86f486935893c708287b30bd050a36ac827ec7fe5e43fe7cb198dd835fba
- build:
- number: 0
- disable_pip: true
- skip: True # [py<37]
- entry_points:
- - pip = pip._internal.cli.main:main
- - pip3 = pip._internal.cli.main:main
- requirements:
- host:
- - python
- - setuptools
- - wheel
- run:
- - python
- - setuptools
- - wheel
- test:
- commands:
- - pip -h
- - pip list
- imports:
- - pip
- about:
- home: https://pip.pypa.io/en/stable/
- license: MIT
- license_family: MIT
- license_file: LICENSE.txt
- summary: PyPA recommended tool for installing Python packages
- doc_url: https://pip.pypa.io/en/stable/
- dev_url: https://github.com/pypa/pip
- extra:
- recipe-maintainers:
- - jakirkham
- - msarahan
- - pelson
- - ocefpaf
- - mingwandroid
|