meta.yaml.template 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. {% set version = "23.1.2" %}
  2. # make sure to set CONDA_ADD_PIP_AS_PYTHON_DEPENDENCY=0 environ-variable before building it
  3. package:
  4. name: pip
  5. version: {{ version }}
  6. source:
  7. url: https://pypi.io/packages/source/p/pip/pip-{{ version }}.tar.gz
  8. sha256: 0e7c86f486935893c708287b30bd050a36ac827ec7fe5e43fe7cb198dd835fba
  9. build:
  10. number: 0
  11. disable_pip: true
  12. skip: True # [py<37]
  13. entry_points:
  14. - pip = pip._internal.cli.main:main
  15. - pip3 = pip._internal.cli.main:main
  16. requirements:
  17. host:
  18. - python
  19. - setuptools
  20. - wheel
  21. run:
  22. - python
  23. - setuptools
  24. - wheel
  25. test:
  26. commands:
  27. - pip -h
  28. - pip list
  29. imports:
  30. - pip
  31. about:
  32. home: https://pip.pypa.io/en/stable/
  33. license: MIT
  34. license_family: MIT
  35. license_file: LICENSE.txt
  36. summary: PyPA recommended tool for installing Python packages
  37. doc_url: https://pip.pypa.io/en/stable/
  38. dev_url: https://github.com/pypa/pip
  39. extra:
  40. recipe-maintainers:
  41. - jakirkham
  42. - msarahan
  43. - pelson
  44. - ocefpaf
  45. - mingwandroid