meta.yaml.template 3.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. {% set name = "pcre2" %}
  2. {% set version = "10.37" %}
  3. package:
  4. name: {{ name }}
  5. version: {{ version }}
  6. source:
  7. url: https://github.com/PhilipHazel/{{ name }}/releases/download/{{ name }}-{{ version }}/{{ name }}-{{ version }}.tar.bz2
  8. sha256: 4d95a96e8b80529893b4562be12648d798b957b1ba1aae39606bbc2ab956d270
  9. build:
  10. number: 1
  11. run_exports:
  12. # https://abi-laboratory.pro/index.php?view=timeline&l=pcre2
  13. - {{ pin_subpackage("pcre2", max_pin="x.x") }}
  14. requirements:
  15. build:
  16. - {{ compiler('c') }}
  17. - cmake
  18. - ninja
  19. - posix # [win]
  20. - m2-sed # [win]
  21. host:
  22. - bzip2
  23. - zlib
  24. test:
  25. commands:
  26. - pcre2test --version
  27. - pcre2grep --version
  28. - pcre2-config --version # [not win]
  29. - test -f ${PREFIX}/include/pcre2.h # [not win]
  30. - test -f ${PREFIX}/include/pcre2posix.h # [not win]
  31. - test -f ${PREFIX}/lib/libpcre2-posix${SHLIB_EXT} # [not win]
  32. - test -f ${PREFIX}/lib/libpcre2-posix.3${SHLIB_EXT} # [osx]
  33. - test -f ${PREFIX}/lib/libpcre2-posix${SHLIB_EXT}.3 # [linux]
  34. - test -f ${PREFIX}/lib/libpcre2-posix${SHLIB_EXT}.3.0.0 # [linux]
  35. - test -f ${PREFIX}/lib/libpcre2-8${SHLIB_EXT} # [not win]
  36. - test -f ${PREFIX}/lib/libpcre2-8.0${SHLIB_EXT} # [osx]
  37. - test -f ${PREFIX}/lib/libpcre2-8${SHLIB_EXT}.0 # [linux]
  38. - test -f ${PREFIX}/lib/libpcre2-8${SHLIB_EXT}.0.10.2 # [linux]
  39. - test -f ${PREFIX}/lib/libpcre2-16${SHLIB_EXT} # [not win]
  40. - test -f ${PREFIX}/lib/libpcre2-16.0${SHLIB_EXT} # [osx]
  41. - test -f ${PREFIX}/lib/libpcre2-16${SHLIB_EXT}.0 # [linux]
  42. - test -f ${PREFIX}/lib/libpcre2-16${SHLIB_EXT}.0.10.2 # [linux]
  43. - test -f ${PREFIX}/lib/libpcre2-32${SHLIB_EXT} # [not win]
  44. - test -f ${PREFIX}/lib/libpcre2-32.0${SHLIB_EXT} # [osx]
  45. - test -f ${PREFIX}/lib/libpcre2-32${SHLIB_EXT}.0 # [linux]
  46. - test -f ${PREFIX}/lib/libpcre2-32${SHLIB_EXT}.0.10.2 # [linux]
  47. - test -f ${PREFIX}/lib/pkgconfig/libpcre2-8.pc # [not win]
  48. - test -f ${PREFIX}/lib/pkgconfig/libpcre2-16.pc # [not win]
  49. - test -f ${PREFIX}/lib/pkgconfig/libpcre2-32.pc # [not win]
  50. - test -f ${PREFIX}/lib/pkgconfig/libpcre2-posix.pc # [not win]
  51. - if not exist %LIBRARY_INC%\\pcre2.h exit 1 # [win]
  52. - if not exist %LIBRARY_INC%\\pcre2posix.h exit 1 # [win]
  53. - if not exist %LIBRARY_BIN%\\pcre2-8.dll exit 1 # [win]
  54. - if not exist %LIBRARY_BIN%\\pcre2-posix.dll exit 1 # [win]
  55. - if not exist %LIBRARY_PREFIX%\\lib\\pkgconfig\\libpcre2-posix.pc exit 1 # [win]
  56. - if not exist %LIBRARY_PREFIX%\\lib\\pkgconfig\\libpcre2-8.pc exit 1 # [win]
  57. about:
  58. home: http://www.pcre.org/
  59. license: BSD-3-Clause
  60. license_family: BSD
  61. license_file: LICENCE
  62. summary: Regular expression pattern matching using Perl 5 syntax and semantics.
  63. description: |
  64. The PCRE library is a set of functions that implement regular expression pattern matching
  65. using the same syntax and semantics as Perl 5. PCRE has its own native API, as well as a set of
  66. wrapper functions that correspond to the POSIX regular expression API. The PCRE library is
  67. free, even for building proprietary software.
  68. dev_url: https://github.com/PhilipHazel/pcre2
  69. doc_url: http://www.pcre.org/current/doc/html/
  70. extra:
  71. recipe-maintainers:
  72. - dfornika
  73. - mariusvniekerk
  74. - xhochy