meta.yaml.template 954 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. {% set version = "23.0" %}
  2. package:
  3. name: packaging
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/p/packaging/packaging-{{ version }}.tar.gz
  7. sha256: b6ad297f8907de0fa2fe1ccbd26fdaf387f5f47c7275fedf8cce89f99446cf97
  8. build:
  9. number: 0
  10. skip: True # [py<37]
  11. script: {{ PYTHON }} -m pip install . --no-deps -vv
  12. requirements:
  13. host:
  14. - python
  15. - flit-core
  16. - pip
  17. - setuptools
  18. - wheel
  19. run:
  20. - python
  21. test:
  22. imports:
  23. - packaging
  24. requires:
  25. - pip
  26. commands:
  27. - pip check
  28. about:
  29. home: https://github.com/pypa/packaging
  30. license: Apache-2.0 or BSD-2-Clause
  31. license_file: LICENSE
  32. license_family: Apache
  33. summary: Core utilities for Python packages
  34. doc_url: https://packaging.pypa.io
  35. dev_url: https://github.com/pypa/packaging
  36. doc_source_url: https://github.com/pypa/packaging/tree/main/docs
  37. extra:
  38. recipe-maintainers:
  39. - jakirkham
  40. - nicoddemus
  41. - mingwandroid