meta.yaml.template 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. {% set name = "openssl" %}
  2. {% set version = "3.0.9" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://www.openssl.org/source/{{ name }}-{{ version }}.tar.gz
  8. sha256: eb1ab04781474360f77c318ab89d8c5a03abc38e63d65a603cabbf1b00a1dc90
  9. build:
  10. number: 0
  11. no_link: lib/libcrypto.so.3.0 # [linux]
  12. no_link: lib/libcrypto.3.0.dylib # [osx]
  13. has_prefix_files: # [unix]
  14. - bin/c_rehash # [unix]
  15. - lib/pkgconfig/libcrypto.pc # [unix]
  16. - lib/pkgconfig/libssl.pc # [unix]
  17. - lib/pkgconfig/openssl.pc # [unix]
  18. run_exports:
  19. # openssl's versioning of starting with 3.0 is X.Y.Z (1.x was X.Y.Z(rev)
  20. # https://www.openssl.org/policies/general/versioning-policy.html#minor-release
  21. # This pin allows the patch release to be >= the build-time openssl version.
  22. - {{ pin_subpackage('openssl', max_pin='x') }}
  23. detect_binary_files_with_prefix: True
  24. binary_has_prefix_files:
  25. - lib/libcrypto.so.3.0 # [linux]
  26. - lib/libcrypto.3.0.dylib # [osx]
  27. - lib/libcrypto.a # [unix]
  28. requirements:
  29. build:
  30. - {{ compiler('c') }}
  31. - nasm # [win]
  32. - make # [unix]
  33. - perl
  34. run:
  35. - ca-certificates
  36. test:
  37. requires:
  38. - certifi # [win]
  39. - python 3.8
  40. - six
  41. commands:
  42. - copy NUL checksum.txt # [win]
  43. - touch checksum.txt # [unix]
  44. - openssl sha256 checksum.txt
  45. - openssl ecparam -name prime256v1
  46. - python -c "from six.moves import urllib; urllib.request.urlopen('https://pypi.org')" # [unix]
  47. - python -c "import certifi; import ssl; import urllib.request as urlrq; urlrq.urlopen('https://pypi.org', context=ssl.create_default_context(cafile=certifi.where()))" # [win]
  48. about:
  49. home: https://www.openssl.org/
  50. license_file: LICENSE.txt
  51. license: Apache-2.0
  52. license_family: Apache
  53. summary: OpenSSL is an open-source implementation of the SSL and TLS protocols
  54. description: |
  55. OpenSSL is a robust, commercial-grade, full-featured Open Source Toolkit
  56. for the Transport Layer Security (TLS) protocol formerly known as the
  57. Secure Sockets Layer (SSL) protocol. The protocol implementation is based
  58. on a full-strength general purpose cryptographic library, which can also
  59. be used stand-alone.
  60. dev_url: https://github.com/openssl/openssl
  61. doc_url: https://www.openssl.org/docs/man3.0/
  62. extra:
  63. recipe-maintainers:
  64. - jakirkham
  65. - jjhelmus
  66. - msarahan
  67. - ocefpaf
  68. - pelson
  69. - carlodri
  70. - chenghlee