meta.yaml.template 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. {% set version = "6.4" %}
  2. package:
  3. name: ncurses
  4. version: {{ version }}
  5. source:
  6. fn: ncurses-{{ version }}.tar.gz
  7. url: https://invisible-mirror.net/archives/ncurses/ncurses-{{ version }}.tar.gz
  8. sha256: 6931283d9ac87c5073f30b6290c4c75f21632bb4fc3603ac8100812bed248159
  9. patches:
  10. # http://lists.gnu.org/archive/html/bug-ncurses/2011-04/txtkWQqiQvcZe.txt
  11. - fix.patch
  12. - clang.patch # [osx]
  13. build:
  14. number: 0
  15. skip: True # [win]
  16. run_exports:
  17. # pretty good compat within major version
  18. # https://abi-laboratory.pro/tracker/timeline/ncurses/
  19. - {{ pin_subpackage('ncurses') }}
  20. # A C++ compiler is needed so that the cursesapp.h file is installed,
  21. # but the library does not need libstdc++/libc++
  22. ignore_run_exports:
  23. - libstdcxx-ng
  24. - libcxx
  25. requirements:
  26. build:
  27. - {{ compiler('c') }}
  28. - {{ compiler('cxx') }}
  29. - libtool
  30. - make
  31. - patch
  32. host:
  33. - pkg-config
  34. # Need a separate host section so that ncurses doesn't remove -L$PREFIX/lib
  35. - libcxx # [osx]
  36. - libstdcxx-ng # [linux]
  37. test:
  38. # TODO :: conda-build needs seperate test/requires_build and test/requires_host
  39. requires:
  40. # Tests failed on linux-aarch64, osx-64, and osx-arm64 because pkg-config not found
  41. - pkg-config
  42. about:
  43. home: https://invisible-island.net/ncurses/
  44. # See https://github.com/mirror/ncurses/blob/3ef920d65fb2d4046096131d868ae8d4bba79d46/package/debian/copyright
  45. license: MIT AND X11
  46. license_family: MIT
  47. license_file: COPYING
  48. summary: Library for text-based user interfaces
  49. description: |
  50. The ncurses (new curses) library is a free software
  51. emulation of curses in System V Release 4.0 (SVr4),
  52. and more. It uses terminfo format, supports pads and
  53. color and multiple highlights and forms characters and
  54. function-key mapping, and has all the other SVr4-curses
  55. enhancements over BSD curses. SVr4 curses is better
  56. known today as X/Open Curses
  57. doc_url: https://invisible-island.net/ncurses/NCURSES-Programming-HOWTO.html
  58. dev_url: https://ncurses.scripts.mit.edu/?p=ncurses.git
  59. extra:
  60. recipe-maintainers:
  61. - jakirkham
  62. - jjhelmus
  63. skip-lints:
  64. - build_tools_must_be_in_build
  65. - host_section_needs_exact_pinnings