meta.yaml.template 2.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. {% set pkg_name = "lz4-c" %}
  2. {% set name = "lz4" %}
  3. {% set version = "1.9.4" %}
  4. package:
  5. name: {{ pkg_name }}
  6. version: {{ version }}
  7. source:
  8. fn: {{ name }}-{{ version }}.tar.gz
  9. url: https://github.com/{{ name }}/{{ name }}/archive/v{{ version }}.tar.gz
  10. sha256: 0b0e3aa07c8c063ddf40b082bdf7e37a1562bda40a0ff5272957f3e987e0e54b
  11. build:
  12. number: 0
  13. requirements:
  14. build:
  15. - {{ compiler('c') }}
  16. - {{ compiler('cxx') }} # [not win]
  17. - make # [not win]
  18. - m2-gcc-libs # [win]
  19. host:
  20. run:
  21. outputs:
  22. - name: lz4-c
  23. build:
  24. # https://abi-laboratory.pro/index.php?view=timeline&l=lz4
  25. run_exports:
  26. - {{ pin_subpackage(pkg_name, max_pin='x.x') }}
  27. test:
  28. requires:
  29. - pkg-config # [unix]
  30. commands:
  31. - lz4 -h
  32. - lz4c -h # [unix]
  33. - lz4cat -h # [unix]
  34. - unlz4 -h # [unix]
  35. - test -f ${PREFIX}/include/lz4.h # [unix]
  36. - test -f ${PREFIX}/include/lz4hc.h # [unix]
  37. - test -f ${PREFIX}/include/lz4frame.h # [unix]
  38. - if not exist %LIBRARY_INC%\\lz4.h exit 1 # [win]
  39. - if not exist %LIBRARY_INC%\\lz4hc.h exit 1 # [win]
  40. - if not exist %LIBRARY_INC%\\lz4frame.h exit 1 # [win]
  41. - test ! -f ${PREFIX}/lib/liblz4.a # [unix]
  42. - test -f ${PREFIX}/lib/liblz4.dylib # [osx]
  43. - test -f ${PREFIX}/lib/liblz4.so # [linux]
  44. - if not exist %LIBRARY_BIN%\\liblz4.dll exit 1 # [win]
  45. - if not exist %LIBRARY_LIB%\\liblz4.lib exit 1 # [win]
  46. - if exist %LIBRARY_LIB%\\liblz4_static.lib exit 1 # [win]
  47. - test -f ${PREFIX}/lib/pkgconfig/liblz4.pc # [unix]
  48. - pkg-config --cflags --libs liblz4 # [unix]
  49. - name: lz4-c-static
  50. build:
  51. activate_in_script: true
  52. script: build_static.sh # [unix]
  53. script: bld_static.bat # [win]
  54. test:
  55. commands:
  56. - test -f ${PREFIX}/lib/liblz4.a # [unix]
  57. - if not exist %LIBRARY_LIB%\\liblz4_static.lib exit 1 # [win]
  58. about:
  59. home: https://lz4.github.io/lz4/
  60. license: BSD-2-Clause
  61. license_family: BSD
  62. license_file: lib/LICENSE
  63. summary: Extremely Fast Compression algorithm
  64. description: |
  65. LZ4 is lossless compression algorithm, providing compression speed at 400
  66. MB/s per core (0.16 Bytes/cycle). It features an extremely fast decoder,
  67. with speed in multiple GB/s per core (0.71 Bytes/cycle). A high compression
  68. derivative, called LZ4_HC, is available, trading customizable CPU time for
  69. compression ratio. LZ4 library is provided as open source software using a
  70. BSD license.
  71. dev_url: https://github.com/lz4/lz4
  72. doc_url: https://github.com/lz4/lz4/blob/dev/README.md
  73. extra:
  74. recipe-maintainers:
  75. - mingwandroid
  76. - rmax
  77. - wesm
  78. - xhochy