meta.yaml.template 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. {% set version = "2.10.3" %}
  2. package:
  3. name: libxml2
  4. version: {{ version }}
  5. source:
  6. url: https://gitlab.gnome.org/GNOME/libxml2/-/archive/v{{ version }}/libxml2-v{{ version }}.tar.gz
  7. sha256: 497f12e34790d407ec9e2a190d576c0881a1cd78ff3c8991d1f9e40281a5ff57
  8. patches: # [win]
  9. - 0002-Make-and-install-a-pkg-config-file-on-Windows.patch # [win]
  10. build:
  11. number: 0
  12. run_exports:
  13. # remove symbols at minor versions.
  14. # https://abi-laboratory.pro/tracker/timeline/libxml2/
  15. - {{ pin_subpackage('libxml2', max_pin='x.x') }}
  16. requirements:
  17. build:
  18. - {{ compiler('c') }}
  19. - autoconf # [not win]
  20. - automake # [not win]
  21. - libtool # [not win]
  22. - pkg-config # [not win]
  23. - make # [not win]
  24. - m2-patch # [win]
  25. host:
  26. - icu {{icu}} # [not win]
  27. - libiconv 1.16 # [not linux]
  28. - xz {{xz}} # [not win]
  29. - zlib {{zlib}}
  30. run:
  31. - libiconv # [not linux]
  32. test:
  33. files:
  34. - test.xml
  35. commands:
  36. - xmllint test.xml
  37. about:
  38. home: https://gitlab.gnome.org/GNOME/libxml2/
  39. license: MIT
  40. license_family: MIT
  41. license_file: Copyright
  42. summary: The XML C parser and toolkit of Gnome
  43. description: |
  44. Though libxml2 is written in C a variety of language
  45. bindings make it available in other environments.
  46. doc_url: https://gitlab.gnome.org/GNOME/libxml2/-/wikis/home
  47. dev_url: https://gitlab.gnome.org/GNOME/libxml2/
  48. extra:
  49. recipe-maintainers:
  50. - ocefpaf
  51. - jakirkham
  52. - mingwandroid
  53. - gillins
  54. - jschueller
  55. - msarahan
  56. - scopatz
  57. - chenghlee