meta.yaml.template 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. {% set version = "1.10.0" %}
  2. package:
  3. name: libssh2
  4. version: {{ version }}
  5. source:
  6. url: https://www.libssh2.org/download/libssh2-{{ version }}.tar.gz
  7. sha256: 2d64e90f3ded394b91d3a2e774ca203a4179f69aebee03003e5a6fa621e41d51
  8. build:
  9. number: 2
  10. run_exports:
  11. - {{ pin_subpackage('libssh2') }}
  12. requirements:
  13. build:
  14. - {{ compiler('c') }}
  15. - make # [unix]
  16. # This breaks a dependency cycle:
  17. # curl->libssh2->cmake->curl
  18. - cmake-no-system
  19. host:
  20. - openssl {{ openssl }}
  21. run:
  22. - openssl # exact pin handled through openssl run_exports
  23. test:
  24. commands:
  25. - test -f $PREFIX/include/libssh2.h # [not win]
  26. - test -f $PREFIX/include/libssh2_publickey.h # [not win]
  27. - test -f $PREFIX/include/libssh2_sftp.h # [not win]
  28. - test -f $PREFIX/lib/libssh2.a # [not win]
  29. - test -f $PREFIX/lib/libssh2${SHLIB_EXT} # [not win]
  30. - if not exist %LIBRARY_INC%\\libssh2.h exit 1 # [win]
  31. - if not exist %LIBRARY_INC%\\libssh2_publickey.h exit 1 # [win]
  32. - if not exist %LIBRARY_INC%\\libssh2_sftp.h exit 1 # [win]
  33. - if not exist %LIBRARY_LIB%\\libssh2.lib exit 1 # [win]
  34. about:
  35. home: https://www.libssh2.org/
  36. license: BSD-3-Clause
  37. license_family: BSD
  38. license_file: COPYING
  39. summary: 'the SSH library'
  40. description: |
  41. libssh2 is a library implementing the SSH2 protocol, available under the revised BSD license.
  42. doc_url: https://www.libssh2.org/docs.html
  43. dev_url: https://github.com/libssh2/libssh2
  44. extra:
  45. recipe-maintainers:
  46. - shadowwalkersb