meta.yaml 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. # This file created by conda-build 3.24.0
  2. # meta.yaml template originally from:
  3. # /feedstock/recipe, last modified Fri Jun 2 23:13:24 2023
  4. # ------------------------------------------------
  5. package:
  6. name: libarchive
  7. version: 3.6.2
  8. source:
  9. patches:
  10. - patches/0001-Add-lib-to-CMAKE_FIND_LIBRARY_PREFIXES-for-lzma.patch
  11. - patches/0003-VC9-compatibility-test-for-BCryptDeriveKeyPBKDF2.patch
  12. - patches/0004-VC9-compatibility-define-BCRYPT_SUCCESS.patch
  13. - patches/0006-VC-openssl-define-inline-as-__inline.patch
  14. - patches/0007-CMake-VC9-compatibility-ignore-some-warnings.patch
  15. - patches/0008-VC9-compatibility-remove-C99.patch
  16. - patches/0009-CMake-Force-Multi-threaded-DLL-runtime.patch
  17. sha256: ba6d02f15ba04aba9c23fd5f236bb234eab9d5209e95d1c4df85c44d5f19b9b3
  18. url: https://github.com/libarchive/libarchive/releases/download/v3.6.2/libarchive-3.6.2.tar.gz
  19. build:
  20. number: '2'
  21. run_exports:
  22. - libarchive >=3.6.2,<3.7.0a0
  23. string: h6ac8c49_2
  24. requirements:
  25. build:
  26. - _libgcc_mutex 0.1 main
  27. - _openmp_mutex 5.1 1_gnu
  28. - _sysroot_linux-64_curr_repodata_hack 3 haa98f57_10
  29. - binutils_impl_linux-64 2.38 h2a08ee3_1
  30. - binutils_linux-64 2.38.0 hc2dff05_0
  31. - bzip2 1.0.8 h7b6447c_0
  32. - c-ares 1.19.0 h5eee18b_0
  33. - ca-certificates 2023.01.10 h06a4308_0
  34. - cmake 3.22.1 h1fce559_0
  35. - expat 2.4.9 h6a678d5_0
  36. - gcc_impl_linux-64 11.2.0 h1234567_1
  37. - gcc_linux-64 11.2.0 h5c386dc_0
  38. - kernel-headers_linux-64 3.10.0 h57e8cba_10
  39. - krb5 1.20.1 hf590b9c_0
  40. - ld_impl_linux-64 2.38 h1181459_1
  41. - libcurl 7.88.1 h251f7ec_1
  42. - libedit 3.1.20221030 h5eee18b_0
  43. - libev 4.33 h7f8727e_1
  44. - libgcc-devel_linux-64 11.2.0 h1234567_1
  45. - libgcc-ng 11.2.0 h1234567_1
  46. - libgomp 11.2.0 h1234567_1
  47. - libnghttp2 1.52.0 h2d74bed_0
  48. - libssh2 1.10.0 hdbd6064_1
  49. - libstdcxx-ng 11.2.0 h1234567_1
  50. - libuv 1.44.2 h5eee18b_0
  51. - lz4-c 1.9.4 h6a678d5_0
  52. - ncurses 6.4 h6a678d5_0
  53. - ninja-base 1.10.2 hd09550d_5
  54. - openssl 3.0.8 h7f8727e_0
  55. - patch 2.7.6 h7b6447c_1001
  56. - rhash 1.4.3 hdbd6064_0
  57. - sysroot_linux-64 2.17 h57e8cba_10
  58. - xz 5.4.2 h5eee18b_0
  59. - zlib 1.2.13 h5eee18b_0
  60. - zstd 1.5.5 hc292b87_0
  61. host:
  62. - _libgcc_mutex 0.1 main
  63. - _openmp_mutex 5.1 1_gnu
  64. - bzip2 1.0.8 h7b6447c_0
  65. - ca-certificates 2023.01.10 h06a4308_0
  66. - icu 58.2 he6710b0_3
  67. - libgcc-ng 11.2.0 h1234567_1
  68. - libgomp 11.2.0 h1234567_1
  69. - libstdcxx-ng 11.2.0 h1234567_1
  70. - libxml2 2.10.3 hcbfbd50_0
  71. - lz4-c 1.9.4 h6a678d5_0
  72. - openssl 3.0.8 h7f8727e_0
  73. - xz 5.4.2 h5eee18b_0
  74. - zlib 1.2.13 h5eee18b_0
  75. - zstd 1.5.2 ha4553b6_0
  76. run:
  77. - bzip2 >=1.0.8,<2.0a0
  78. - libgcc-ng >=11.2.0
  79. - libxml2 >=2.10.3,<2.11.0a0
  80. - lz4-c >=1.9.4,<1.10.0a0
  81. - openssl 3.*
  82. - openssl >=3.0.8,<4.0a0
  83. - xz >=5.4.2,<6.0a0
  84. - zlib >=1.2.13,<1.3.0a0
  85. - zstd >=1.5.2,<1.6.0a0
  86. test:
  87. commands:
  88. - test -f "${PREFIX}/lib/pkgconfig/libarchive.pc"
  89. - test -f "${PREFIX}/include/archive.h"
  90. - test -f "${PREFIX}/include/archive_entry.h"
  91. - test -f "${PREFIX}/lib/libarchive.a"
  92. - test -f "${PREFIX}/lib/libarchive${SHLIB_EXT}"
  93. - bsdcat --version
  94. - bsdcpio --version
  95. - bsdtar --version
  96. - pushd test-archives
  97. - bsdtar -vxf hello_world.xar 2>&1 | rg "x hello_world"
  98. - bsdtar -vxf archive.7z 2>&1 | rg "x 7zip-archive"
  99. - bsdtar -vxf hello_world.tar.zst 2>&1 | rg "greets"
  100. - popd
  101. files:
  102. - test-archives/archive.7z
  103. - test-archives/hello_world.tar.zst
  104. - test-archives/hello_world.xar
  105. requires:
  106. - ripgrep
  107. about:
  108. description: 'Libarchive is an open-source BSD-licensed C programming library that
  109. provides streaming access
  110. to a variety of different archive formats, including tar, cpio, pax, Zip, and
  111. ISO9660 images.
  112. The distribution also includes bsdtar and bsdcpio, full-featured implementations
  113. of tar and cpio
  114. that use libarchive.
  115. When reading archives, libarchive uses a robust automatic format detector that
  116. can automatically handle archives
  117. that have been compressed with gzip, bzip2, xz, lzip, and several other popular
  118. compression algorithms.
  119. '
  120. dev_url: https://github.com/libarchive/libarchive
  121. doc_url: https://github.com/libarchive/libarchive/wiki
  122. home: https://libarchive.org/
  123. license: BSD-2-Clause
  124. license_family: BSD
  125. license_file: COPYING
  126. summary: Multi-format archive and compression library
  127. extra:
  128. copy_test_source_files: true
  129. final: true
  130. flow_run_id: 9f5c1244-4c3f-499f-a45f-85b18097f46d
  131. recipe-maintainers:
  132. - jakirkham
  133. - mingwandroid
  134. - ocefpaf
  135. remote_url: git@github.com:AnacondaRecipes/libarchive-feedstock.git
  136. sha: 6ae744557e1e9dff7f62d3c9764bf013fb23a66c
  137. skip-lints:
  138. - host_section_needs_exact_pinnings
  139. - missing_tests