meta.yaml.template 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. {% set version = "1.20.1" %}
  2. package:
  3. name: krb5
  4. version: {{ version }}
  5. source:
  6. url: https://github.com/krb5/krb5/archive/krb5-{{ version }}-final.tar.gz
  7. sha256: ec3861c3bec29aa8da9281953c680edfdab1754d1b1db8761c1d824e4b25496a
  8. build:
  9. number: 1
  10. skip: True # [win and vc<14]
  11. run_exports:
  12. # stable within minor revisions: https://abi-laboratory.pro/tracker/timeline/krb5/
  13. - {{ pin_subpackage('krb5', max_pin='x.x') }}
  14. ignore_run_exports:
  15. # C++ and Tcl are only needed for performing built-in unit tests.
  16. - libcxx # [osx]
  17. - libstdcxx-ng # [linux]
  18. - tk
  19. missing_dso_whitelist: # [osx]
  20. - /usr/lib/libresolv.9.dylib # [osx]
  21. requirements:
  22. build:
  23. - {{ compiler('c') }}
  24. - {{ compiler('cxx') }}
  25. - bison # [not win]
  26. - autoconf # [not win]
  27. - posix # [win]
  28. - perl # [win]
  29. - pkg-config # [unix]
  30. - make # [unix]
  31. host:
  32. - libedit 3.1.20221030 # [unix]
  33. - openssl {{ openssl }} # [unix]
  34. - tk 8.6.12
  35. run:
  36. - {{ pin_compatible('libedit') }} # [unix]
  37. - openssl # exact pin handled through openssl run_exports
  38. test:
  39. requires:
  40. - python 3.11
  41. about:
  42. home: https://web.mit.edu/kerberos/
  43. license: MIT
  44. license_file: doc/notice.rst
  45. license_family: MIT
  46. summary: 'A network authentication protocol.'
  47. description: |
  48. Kerberos is a network authentication protocol. It is designed to provide strong authentication for client/server applications by using secret-key cryptography.
  49. doc_url: https://web.mit.edu/kerberos/krb5-1.20/doc/index.html
  50. dev_url: https://kerberos.org/dist/index.html
  51. extra:
  52. recipe-maintainers:
  53. - pelson
  54. - ocefpaf
  55. - mingwandroid
  56. - mariusvniekerk
  57. - chenghlee