meta.yaml.template 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. {% set name = "jsonpointer" %}
  2. {% set version = "2.1" %}
  3. {% set bundle = "tar.gz" %}
  4. {% set hash_type = "sha256" %}
  5. {% set hash = "5a34b698db1eb79ceac454159d3f7c12a451a91f6334a4f638454327b7a89962" %}
  6. {% set build = 0 %}
  7. package:
  8. name: {{ name|lower }}
  9. version: {{ version }}
  10. source:
  11. fn: {{ name }}-{{ version }}.{{ bundle }}
  12. url: https://pypi.org/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.{{ bundle }}
  13. {{ hash_type }}: {{ hash }}
  14. build:
  15. noarch: python
  16. number: {{ build }}
  17. script: python setup.py install --single-version-externally-managed --record=record.txt
  18. requirements:
  19. build:
  20. - python
  21. - setuptools
  22. run:
  23. - python
  24. test:
  25. imports:
  26. - jsonpointer
  27. about:
  28. home: https://github.com/stefankoegl/python-json-pointer
  29. license: BSD 3-Clause
  30. license_family: BSD
  31. license_file: LICENSE.txt
  32. summary: 'Identify specific nodes in a JSON document (RFC 6901)'
  33. dev_url: https://github.com/stefankoegl/python-json-pointer
  34. doc_url: https://python-json-pointer.readthedocs.io/en/latest/
  35. extra:
  36. recipe-maintainers:
  37. - anguslees
  38. - pmlandwehr