meta.yaml.template 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. {% set name = "jsonpatch" %}
  2. {% set version = "1.32" %}
  3. {% set bundle = "tar.gz" %}
  4. {% set hash_type = "sha256" %}
  5. {% set hash_val = "b6ddfe6c3db30d81a96aaeceb6baf916094ffa23d7dd5fa2c13e13f8b6e600c2" %}
  6. package:
  7. name: {{ name }}
  8. version: {{ version }}
  9. source:
  10. fn: {{ name }}-{{ version }}.{{ bundle }}
  11. url: https://pypi.org/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.{{ bundle }}
  12. {{ hash_type }}: {{ hash_val }}
  13. build:
  14. number: 0
  15. noarch: python
  16. script: python -m pip install --no-deps --ignore-installed .
  17. requirements:
  18. build:
  19. - python
  20. - pip
  21. run:
  22. - python
  23. - jsonpointer >=1.9
  24. test:
  25. imports:
  26. - jsonpatch
  27. about:
  28. home: https://github.com/stefankoegl/python-json-patch
  29. license: BSD 3-Clause
  30. license_family: BSD
  31. license_file: COPYING
  32. summary: 'Apply JSON-Patches (RFC 6902)'
  33. dev_url: https://github.com/stefankoegl/python-json-patch
  34. doc_url: https://python-json-patch.readthedocs.io/en/latest/
  35. extra:
  36. recipe-maintainers:
  37. - anguslees
  38. - pmlandwehr