meta.yaml.template 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. {% set name = "fmt" %}
  2. {% set version = "9.1.0" %}
  3. {% set sha256 = "5dea48d1fcddc3ec571ce2058e13910a0d4a6bab4cc09a809d8b1dd1c88ae6f2" %}
  4. {% set build_number = "0" %}
  5. package:
  6. name: {{ name|lower }}
  7. version: {{ version }}
  8. source:
  9. url: https://github.com/fmtlib/{{ name }}/archive/{{ version }}.tar.gz
  10. sha256: {{ sha256 }}
  11. build:
  12. number: {{ build_number }}
  13. # Trigger 1
  14. skip: true # [win and vc<14]
  15. run_exports:
  16. - {{ pin_subpackage('fmt', max_pin='x') }}
  17. requirements:
  18. build:
  19. - {{ compiler('cxx') }}
  20. - cmake
  21. - ninja
  22. test:
  23. commands:
  24. - test -d ${PREFIX}/include/fmt # [unix]
  25. - test -f ${PREFIX}/include/fmt/core.h # [unix]
  26. - test -f ${PREFIX}/include/fmt/format.h # [unix]
  27. - test -f ${PREFIX}/lib/cmake/fmt/fmt-config.cmake # [unix]
  28. - test -f ${PREFIX}/lib/libfmt.so # [linux]
  29. - test -f ${PREFIX}/lib/libfmt.dylib # [osx]
  30. - if exist %LIBRARY_PREFIX%\include\fmt\core.h (exit 0) else (exit 1) # [win]
  31. - if exist %LIBRARY_PREFIX%\include\fmt\format.h (exit 0) else (exit 1) # [win]
  32. - if exist %LIBRARY_PREFIX%\lib\cmake\fmt-config.cmake (exit 0) else (exit 1) # [win]
  33. - if exist %LIBRARY_PREFIX%\bin\fmt.dll (exit 0) else (exit 1) # [win]
  34. about:
  35. home: https://fmt.dev/latest/
  36. license: MIT
  37. license_family: MIT
  38. license_file: LICENSE.rst
  39. summary: '{fmt} is an open-source formatting library for C++'
  40. description: |
  41. {fmt} is an open-source formatting library for C++.
  42. It can be used as a safe and fast alternative to (s)printf and iostreams.
  43. dev_url: https://github.com/fmtlib/fmt
  44. doc_url: https://fmt.dev/latest/
  45. extra:
  46. recipe-maintainers:
  47. - tdegeus
  48. - vitaut
  49. - saraedum