meta.yaml.template 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. {% set version = "39.0.1" %}
  2. package:
  3. name: cryptography
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/c/cryptography/cryptography-{{ version }}.tar.gz
  7. sha256: d1f6198ee6d9148405e49887803907fe8962a23e6c6f83ea7d98f1c0de375695
  8. build:
  9. number: 2
  10. skip: true # [py<37 or win32]
  11. script: {{ PYTHON }} -m pip install . -vv --no-deps --no-build-isolation
  12. missing_dso_whitelist: # [s390x]
  13. - $RPATH/ld64.so.1 # [s390x]
  14. requirements:
  15. build:
  16. - {{ compiler('rust') }}
  17. - vs2017_{{ target_platform }} # [win]
  18. host:
  19. - python
  20. - cffi >=1.12
  21. - pip
  22. - setuptools >=40.6.0,!=60.9.0
  23. - setuptools-rust >=0.11.4
  24. - wheel
  25. run:
  26. - python
  27. - cffi >=1.12
  28. - openssl 3.*
  29. - libgcc-ng # [linux]; needed by `_rust.abi3.so`
  30. test:
  31. requires:
  32. - cryptography-vectors {{ version }}
  33. - hypothesis >=1.11.4,!=3.79.2
  34. - iso8601
  35. - pip
  36. - pretend
  37. - pytest >=6.2.0
  38. - pytest-subtests
  39. - pytest-xdist
  40. - pytest-benchmark
  41. - pytz
  42. source_files:
  43. - tests
  44. commands:
  45. - pip check
  46. # run_test.py will check that the correct openssl version is linked
  47. - pytest -n auto # [not arm64]
  48. - pytest -n auto -k "not (test_der_x509_certificate_extensions[x509/PKITS_data/certs/ValidcRLIssuerTest28EE.crt] or test_x509_csr_extensions or test_no_leak_free or test_no_leak_no_malloc or test_leak or test_load_pkcs12_key_and_certificates[pkcs12/cert-key-aes256cbc.p12] or test_create_certificate_with_extensions or test_ec_derive_private_key or test_ec_private_numbers_private_key or test_create_ocsp_request or test_write_pkcs12_key_and_certificates or test_errors or test_load_pkcs12_key_and_certificates[pkcs12/cert-aes256cbc-no-key.p12] or test_ec_private_numbers_private_key or test_pem_x509_certificate_extensions[x509/cryptography.io.pem] or test_create_crl_with_idp or test_no_leak_gc or test_x25519_pubkey_from_private_key)" # [arm64]
  49. about:
  50. home: https://github.com/pyca/cryptography
  51. license: (BSD-3-Clause OR Apache-2.0) AND PSF-2.0 AND MIT
  52. license_family: BSD
  53. license_url: https://github.com/pyca/cryptography/blob/{{ version }}/vectors/LICENSE
  54. summary: Provides cryptographic recipes and primitives to Python developers
  55. description: |
  56. Cryptography is a package which provides cryptographic recipes and
  57. primitives to Python developers. Our goal is for it to be your
  58. "cryptographic standard library". It supports Python 3.6+ and PyPy3 7.2+.
  59. cryptography includes both high level recipes and low level interfaces to
  60. common cryptographic algorithms such as symmetric ciphers, message digests,
  61. and key derivation functions.
  62. doc_url: https://cryptography.io/en/{{ version }}/
  63. dev_url: https://github.com/pyca/cryptography
  64. extra:
  65. recipe-maintainers:
  66. - jakirkham
  67. - ocefpaf
  68. - chenghlee