meta.yaml.template 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. {% set name = "conda-package-streaming" %}
  2. {% set version = "0.8.0" %}
  3. package:
  4. name: {{ name|lower }}
  5. version: {{ version }}
  6. source:
  7. url: https://github.com/conda/conda-package-streaming/archive/refs/tags/v{{ version }}.tar.gz
  8. sha256: 5e5212153e285a48223c70ede741d00304725a11cb690c494464a12f04c607f5
  9. build:
  10. number: 0
  11. skip: True # [py<37]
  12. script: {{ PYTHON }} -m pip install --no-deps --no-build-isolation . -vv
  13. requirements:
  14. host:
  15. - flit-core
  16. - python
  17. - pip
  18. - wheel
  19. run:
  20. - python
  21. - zstandard >=0.15
  22. # 'requests' is optional, only needed for 'url' submodule
  23. test:
  24. imports:
  25. - conda_package_streaming
  26. - conda_package_streaming.url
  27. requires:
  28. - pip
  29. - requests
  30. commands:
  31. - pip check
  32. about:
  33. home: https://github.com/conda/conda-package-streaming
  34. summary: An efficient library to read from new and old format .conda and .tar.bz2 conda packages.
  35. description: |
  36. An efficient library to read from new and old format .conda and .tar.bz2 conda packages.
  37. license: BSD-3-Clause
  38. license_family: BSD
  39. license_file: LICENSE
  40. doc_url: https://conda.github.io/conda-package-streaming/
  41. dev_url: https://github.com/conda/conda-package-streaming
  42. extra:
  43. recipe-maintainers:
  44. - dholth