meta.yaml.template 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. {% set name = "conda-package-handling" %}
  2. {% set version = "2.1.0" %}
  3. package:
  4. name: {{ name }}
  5. version: {{ version }}
  6. source:
  7. url: https://github.com/conda/conda-package-handling/archive/{{ version }}.tar.gz
  8. sha256: dcaa757fca94857420acd21b27d1ff6939e34522d196c3bafdd6dfed90559da5
  9. build:
  10. number: 0
  11. skip: True # [py<37]
  12. script: {{ PYTHON }} -m pip install . --no-deps --no-build-isolation -vv
  13. entry_points:
  14. - cph = conda_package_handling.cli:main
  15. requirements:
  16. build:
  17. - python
  18. host:
  19. - python
  20. - pip
  21. - setuptools
  22. - wheel
  23. run:
  24. - python
  25. - conda-package-streaming >=0.7.0
  26. test:
  27. source_files:
  28. - tests
  29. requires:
  30. - mock
  31. - pip
  32. - pytest
  33. - pytest-cov
  34. - pytest-mock
  35. - requests # optional, here to please pip check
  36. imports:
  37. - conda_package_handling
  38. - conda_package_handling.api
  39. commands:
  40. - pip check
  41. - pytest -v --cov=conda_package_handling --color=yes tests/
  42. about:
  43. home: https://github.com/conda/conda-package-handling
  44. dev_url: https://github.com/conda/conda-package-handling
  45. doc_url: https://conda.github.io/conda-package-handling/
  46. license: BSD-3-Clause
  47. license_family: BSD
  48. license_file:
  49. - LICENSE
  50. summary: Create and extract conda packages of various formats
  51. description: |
  52. cph is an abstraction of conda package handling and a tool for extracting, creating, and converting between formats.
  53. extra:
  54. recipe-maintainers:
  55. - beckermr
  56. - dbast
  57. - dholth
  58. - jezdez