meta.yaml.template 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. {% set name = "conda-libmamba-solver" %}
  2. {% set version = "23.5.0" %}
  3. package:
  4. name: {{ name }}
  5. version: {{ version }}
  6. source:
  7. url: https://github.com/conda/{{ name }}/archive/refs/tags/{{ version }}.tar.gz
  8. sha256: b796a867b4b2d40ab38159681f1db1c287385b85787be5199569d8f08326ca09
  9. folder: src/
  10. build:
  11. number: 0
  12. skip: true # [py<38]
  13. script_env:
  14. - SETUPTOOLS_SCM_PRETEND_VERSION={{version}}
  15. script: {{ PYTHON }} -m pip install src/ -vv --no-deps --no-build-isolation
  16. requirements:
  17. host:
  18. - python
  19. - pip
  20. - wheel
  21. - setuptools
  22. - hatchling
  23. - hatch-vcs
  24. run:
  25. - python
  26. - conda >=23.5.0
  27. - libmambapy >=1.4.1
  28. - boltons >=23.0.0
  29. test:
  30. imports:
  31. - conda_libmamba_solver
  32. commands:
  33. - CONDA_SOLVER=libmamba conda create -n test --dry-run scipy # [not win] Not crosss platform.
  34. - conda create --solver libmamba -n test --dry-run scipy
  35. about:
  36. home: https://github.com/conda/conda-libmamba-solver
  37. license: BSD-3-Clause
  38. license_family: BSD
  39. license_file: src/LICENSE
  40. summary: 'The fast mamba solver, now in conda!'
  41. description: |
  42. The conda-libmamba-solver is a new solver for the conda package manager
  43. which uses the solver from the mamba project behind the scenes,
  44. while carefully implementing conda's functionality and expected behaviors on top.
  45. The library used by mamba to do the heavy-lifting is called libsolv.
  46. dev_url: https://github.com/conda/conda-libmamba-solver
  47. doc_url: https://conda.github.io/conda-libmamba-solver/
  48. extra:
  49. recipe-maintainers:
  50. - jaimergp
  51. - jezdez
  52. - wolfv
  53. skip-lints:
  54. - missing_pip_check