meta.yaml.template 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. {% set name = "conda-content-trust" %}
  2. {% set version = "0.1.3" %}
  3. {% set sha256 = "50a2732dcf3612bdff2b36171e3ebc72a74bbc258543a5aa2618218406b30a0d" %}
  4. package:
  5. name: {{ name }}
  6. version: {{ version }}
  7. source:
  8. fn: {{ name|lower }}-{{ version }}.tar.gz
  9. url: https://github.com/conda/{{ name }}/archive/{{ version }}.tar.gz
  10. sha256: {{ sha256 }}
  11. build:
  12. number: 0
  13. script: {{ PYTHON }} -m pip install --no-deps --ignore-installed -vv .
  14. entry_points:
  15. - conda-content-trust = conda_content_trust.cli:cli
  16. requirements:
  17. host:
  18. - python
  19. - pip
  20. - setuptools
  21. - wheel
  22. run:
  23. - python
  24. - cryptography
  25. - six
  26. test:
  27. source_files:
  28. - tests
  29. imports:
  30. - conda_content_trust
  31. requires:
  32. - pip
  33. - pytest
  34. - pytest-cov
  35. - ruamel_yaml
  36. commands:
  37. - pip check
  38. - pytest -v tests
  39. - conda-content-trust --help
  40. about:
  41. home: https://github.com/conda/conda-content-trust
  42. license: BSD-3-Clause
  43. license_family: BSD
  44. license_file: LICENSE
  45. summary: Signing and verification tools for conda
  46. dev_url: https://github.com/conda/conda-content-trust
  47. doc_url: https://github.com/conda/conda-content-trust/blob/main/README.rst