meta.yaml.template 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. {% set name = "conda" %}
  2. {% set version = "23.5.2" %}
  3. {% set build_number = "0" %}
  4. {% set sha256 = "c82ab703f1784cd1ffa4cfad5fe80f1e994b9b7a612e9268ddd136c5ad19188e" %}
  5. # Running the upstream test suite requires the inclusion of test files, which
  6. # balloons the size of the package and occasionally triggers false-positive
  7. # security warnings; values can be "yes" or "no".
  8. {% set run_upstream_tests = "no" %}
  9. package:
  10. name: {{ name }}
  11. version: {{ version }}
  12. source:
  13. url: https://github.com/conda/{{ name }}/archive/{{ version }}.tar.gz
  14. sha256: {{ sha256 }}
  15. build:
  16. skip: True # [py<38]
  17. number: {{ build_number }}
  18. script: {{ PYTHON }} -m pip install . --no-deps --no-build-isolation -vv && {{ PYTHON }} -m conda init --install
  19. # These are present when the new environment is created
  20. # so we have to exempt them from the list of initial files
  21. # for conda-build to realize they should be included.
  22. always_include_files:
  23. - bin/conda # [unix]
  24. - bin/activate # [unix]
  25. - bin/deactivate # [unix]
  26. - Scripts/activate.bat # [win]
  27. - Scripts/activate # [win]
  28. - Scripts/deactivate # [win]
  29. requirements:
  30. build:
  31. - git # [not win]
  32. - m2-filesystem # [win]
  33. - m2-bash # [win]
  34. - m2-base # [win]
  35. host:
  36. - python
  37. - pip
  38. - hatchling >=1.12.2
  39. - hatch-vcs >=0.2.0
  40. - wheel
  41. # for `conda init` in build/script above
  42. - ruamel.yaml >=0.11.14,<0.18
  43. - tqdm >=4
  44. - menuinst >=1.4.11,<2 # [win]
  45. run:
  46. - python
  47. - conda-package-handling >=1.3.0
  48. - menuinst >=1.4.11,<2 # [win]
  49. - packaging >=23.0
  50. - pycosat >=0.6.3
  51. - pyopenssl >=16.2.0
  52. - requests >=2.20.1,<3
  53. - ruamel.yaml >=0.11.14,<0.18
  54. - setuptools >=31.0.1
  55. - toolz >=0.8.1
  56. - pluggy >=1.0.0
  57. - tqdm >=4
  58. - boltons >=23.0.0
  59. - jsonpatch >=1.32
  60. run_constrained:
  61. - conda-build >=3.18.3
  62. - conda-content-trust >=0.1.1
  63. - conda-env >=2.6
  64. - cytoolz >=0.8.1
  65. - conda-libmamba-solver >=22.12.0
  66. test:
  67. {% if run_upstream_tests == 'yes' %}
  68. source_files:
  69. - tests
  70. - setup.cfg
  71. {% endif %}
  72. requires:
  73. {% if run_upstream_tests == 'yes' %}
  74. - mock
  75. - pytest
  76. - pexpect
  77. - responses
  78. # - conda-build # needed to run the test suite, but we're not doing that right now.
  79. {% endif %}
  80. - m2-filesystem # [win]
  81. - m2-bash # [win]
  82. - m2-base # [win]
  83. imports:
  84. - conda
  85. - conda_env
  86. downstreams:
  87. - conda-smithy # [py3k]
  88. about:
  89. home: https://docs.conda.io
  90. license: BSD-3-Clause
  91. license_family: BSD
  92. license_file: LICENSE
  93. summary: OS-agnostic, system-level binary package and environment manager.
  94. description: |
  95. Conda is an open source package management system and environment
  96. management system for installing multiple versions of software packages
  97. and their dependencies and switching easily between them. It works on
  98. Linux, OS X and Windows, and was created for Python programs but can
  99. package and distribute any software.
  100. doc_url: https://docs.conda.io/projects/conda/en/stable/
  101. dev_url: https://github.com/conda/conda
  102. extra:
  103. skip-lints:
  104. - python_build_tool_in_run
  105. - missing_pip_check