meta.yaml.template 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. {% set version = "1.15.1" %}
  2. package:
  3. name: cffi
  4. version: {{ version }}
  5. source:
  6. url: https://pypi.io/packages/source/c/cffi/cffi-{{ version }}.tar.gz
  7. sha256: d400bfb9a37b1351253cb402671cea7e89bdecc294e8016a707f6d1d8ac934f9
  8. patches:
  9. - setup-linux.patch # [not win]
  10. - 0001-Link-to-dl-library.patch
  11. - apple-jit.patch # [osx]
  12. build:
  13. number: 3
  14. script: {{ PYTHON }} -m pip install . --no-deps -vv
  15. missing_dso_whitelist:
  16. - $RPATH/ld64.so.1 # [s390x]
  17. requirements:
  18. build:
  19. - {{ compiler('c') }}
  20. - patch # [not win]
  21. - m2-patch # [win]
  22. host:
  23. - python
  24. - pip
  25. - setuptools
  26. - wheel
  27. run:
  28. - python
  29. # set lower bound to avoid hotfix to lower it to <3.3
  30. - libffi >=3.4,<3.5 # [not win]
  31. - pycparser
  32. test:
  33. imports:
  34. - cffi
  35. - _cffi_backend
  36. requires:
  37. - pip
  38. commands:
  39. - pip check
  40. about:
  41. home: https://cffi.readthedocs.org/
  42. license: MIT
  43. license_family: MIT
  44. license_file: LICENSE
  45. summary: Foreign Function Interface for Python calling C code.
  46. description: |
  47. Cffi aims to allow users to call C code from Python without having to
  48. learn a 3rd language. It provides a convenient and reliable way to call
  49. compiled C code from Python using interface declarations written in C.
  50. doc_url: https://cffi.readthedocs.io/en/latest/
  51. dev_url: https://foss.heptapod.net/pypy/cffi
  52. doc_source_url: https://foss.heptapod.net/pypy/cffi/-/tree/branch/default/doc/source
  53. extra:
  54. recipe-maintainers:
  55. - goanpeca
  56. - inducer
  57. - ocefpaf
  58. - mingwandroid