meta.yaml.template 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. {% set version = "2023.5.7" %}
  2. {% set pip_version = "20.2.3" %}
  3. {% set setuptools_version = "49.6.0" %}
  4. package:
  5. name: certifi
  6. version: {{ version }}
  7. source:
  8. - url: https://pypi.io/packages/source/c/certifi/certifi-{{ version }}.tar.gz
  9. sha256: 0f0d56dc5a6ad56fd4ba36484d6cc34451e1c6548c61daad8c320169f91eddc7
  10. folder: certifi
  11. # bootstrap pip and setuptools to avoid circular dependency
  12. # but without losing metadata
  13. # Please note when using conda-build locally, may get following error: certifi cannot depend on itself
  14. # Try pushing and refer to Prefect logs
  15. - url: https://pypi.io/packages/py2.py3/p/pip/pip-{{ pip_version }}-py2.py3-none-any.whl
  16. sha256: 0f35d63b7245205f4060efe1982f5ea2196aa6e5b26c07669adcf800e2542026
  17. folder: pip_wheel
  18. - url: https://pypi.io/packages/py3/s/setuptools/setuptools-{{ setuptools_version }}-py3-none-any.whl
  19. sha256: 4dd5bb0a0a0cff77b46ca5dd3a84857ee48c83e8223886b556613c724994073f
  20. folder: setuptools_wheel
  21. build:
  22. number: 0
  23. skip: True # [py<36]
  24. requirements:
  25. host:
  26. - python
  27. - wheel
  28. run:
  29. - python
  30. test:
  31. requires:
  32. - pip
  33. commands:
  34. - pip check
  35. imports:
  36. - certifi
  37. about:
  38. home: https://certifi.io/
  39. license: MPL-2.0
  40. license_file: certifi/LICENSE
  41. license_family: Other
  42. summary: Python package for providing Mozilla's CA Bundle.
  43. description: |
  44. Certifi is a curated collection of Root Certificates for validating the
  45. trustworthiness of SSL certificates while verifying the identity of TLS
  46. hosts.
  47. doc_url: https://github.com/certifi/python-certifi/blob/master/README.rst
  48. dev_url: https://github.com/certifi/python-certifi
  49. extra:
  50. recipe-maintainers:
  51. - jakirkham
  52. - pelson
  53. - sigmavirus24
  54. - ocefpaf
  55. - mingwandroid