meta.yaml.template 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. {% set version = "1.0.8" %}
  2. package:
  3. name: bzip2
  4. version: {{ version }}
  5. source:
  6. url: https://sourceware.org/pub/bzip2/bzip2-{{ version }}.tar.gz
  7. sha256: ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269
  8. patches:
  9. - 0001-cross.patch
  10. build:
  11. number: 0
  12. run_exports:
  13. - {{ pin_subpackage('bzip2') }}
  14. requirements:
  15. build:
  16. - {{ compiler('c') }}
  17. - jom # [win]
  18. - make # [unix]
  19. test:
  20. commands:
  21. - bzip2 --help # [unix]
  22. {% set bzip2_executables = [
  23. "bunzip2",
  24. "bzcat",
  25. "bzcmp",
  26. "bzdiff",
  27. "bzegrep",
  28. "bzfgrep",
  29. "bzgrep",
  30. "bzip2recover",
  31. "bzip2",
  32. "bzless",
  33. "bzmore"
  34. ] %}
  35. {% for executable in bzip2_executables %}
  36. - test -f ${PREFIX}/bin/{{ executable }} # [unix]
  37. {% endfor %}
  38. - test -f ${PREFIX}/include/bzlib.h # [unix]
  39. - test -f ${PREFIX}/lib/libbz2.a # [unix]
  40. - test -f ${PREFIX}/lib/libbz2.so # [linux]
  41. - test -f ${PREFIX}/lib/libbz2.dylib # [osx]
  42. - if not exist %LIBRARY_INC%\\bzlib.h exit 1 # [win]
  43. - if not exist %LIBRARY_LIB%\\bzip2.lib exit 1 # [win]
  44. - if not exist %LIBRARY_BIN%\\bzip2.dll exit 1 # [win]
  45. - if not exist %LIBRARY_LIB%\\libbz2.lib exit 1 # [win]
  46. - if not exist %LIBRARY_BIN%\\libbz2.dll exit 1 # [win]
  47. - if not exist %LIBRARY_LIB%\\bzip2_static.lib exit 1 # [win]
  48. - if not exist %LIBRARY_LIB%\\libbz2_static.lib exit 1 # [win]
  49. about:
  50. home: http://www.bzip.org/
  51. license_family: BSD
  52. license_file: LICENSE
  53. license: bzip2
  54. summary: high-quality data compressor
  55. description: |
  56. Bzip2 is a freely available high-quality data compressor. It typically
  57. compresses files to within 10% to 15% of the best available techniques,
  58. whilst being around twice as fast at compression and six times faster
  59. at decompression.
  60. doc_url: http://www.bzip.org/docs.html
  61. extra:
  62. recipe-maintainers:
  63. - jakirkham
  64. - jjhelmus
  65. - pelson
  66. - jlanga
  67. - mingwandroid
  68. - msarahan