meta.yaml.template 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. {% set name = "brotlipy" %}
  2. {% set version = "0.7.0" %}
  3. {% set sha256 = "36def0b859beaf21910157b4c33eb3b06d8ce459c942102f16988cca6ea164df" %}
  4. {% set cross = False %}
  5. {% if build_platform != target_platform and not build_platform.startswith('win') %}
  6. {% set cross = True %}
  7. {% endif %}
  8. package:
  9. name: {{ name|lower }}
  10. version: {{ version }}
  11. source:
  12. fn: {{ name }}-{{ version }}.tar.gz
  13. url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
  14. sha256: {{ sha256 }}
  15. build:
  16. number: 1003
  17. script: python setup.py install --single-version-externally-managed --record=record.txt
  18. requirements:
  19. build:
  20. {% if cross %}
  21. - python
  22. - cross-python_{{ target_platform }}
  23. - cffi >=1.0.0
  24. {% endif %}
  25. - {{ compiler('c') }}
  26. host:
  27. - python
  28. - setuptools
  29. - cffi >=1.0.0
  30. run:
  31. - python
  32. - cffi >=1.0.0
  33. - enum34 # [py2k]
  34. test:
  35. imports:
  36. - brotli
  37. about:
  38. home: https://github.com/python-hyper/brotlipy
  39. license: MIT
  40. license_family: MIT
  41. license_file: LICENSE
  42. summary: 'Python bindings to the Brotli compression library'
  43. dev_url: https://github.com/python-hyper/brotlipy
  44. extra:
  45. recipe-maintainers:
  46. - primozgodec
  47. - astaric
  48. - isuruf