meta.yaml.template 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. {% set name = "boltons" %}
  2. {% set version = "23.0.0" %}
  3. {% set hash = "9b2998cd9525ed472079c7dd90fbd216a887202e8729d5969d4f33878f0ff668" %}
  4. package:
  5. name: {{ name }}
  6. version: {{ version }}
  7. source:
  8. fn: boltons-{{ version }}.tar.gz
  9. url: https://github.com/mahmoud/boltons/archive/{{ version }}.tar.gz
  10. sha256: {{ hash }}
  11. build:
  12. number: 0
  13. script: {{ PYTHON }} -m pip install . --no-deps -vv
  14. requirements:
  15. host:
  16. - pip
  17. - python
  18. - setuptools
  19. - wheel
  20. run:
  21. - python
  22. test:
  23. source_files:
  24. - boltons
  25. - tests
  26. - pytest.ini
  27. imports:
  28. - boltons
  29. - boltons.cacheutils
  30. - boltons.debugutils
  31. - boltons.dictutils
  32. - boltons.ecoutils
  33. - boltons.fileutils
  34. - boltons.formatutils
  35. - boltons.funcutils
  36. - boltons.gcutils
  37. - boltons.ioutils
  38. - boltons.iterutils
  39. - boltons.jsonutils
  40. - boltons.listutils
  41. - boltons.mathutils
  42. - boltons.mboxutils
  43. - boltons.namedutils
  44. - boltons.pathutils
  45. - boltons.queueutils
  46. - boltons.setutils
  47. - boltons.socketutils
  48. - boltons.statsutils
  49. - boltons.strutils
  50. - boltons.tableutils
  51. - boltons.tbutils
  52. - boltons.timeutils
  53. - boltons.typeutils
  54. - boltons.urlutils
  55. requires:
  56. - pytest
  57. - pip
  58. commands:
  59. # tests/test_jsonutils.py::test_reverse_iter_lines fails due to line endings on windows.
  60. - pytest -vv --doctest-modules boltons tests -k "not test_reverse_iter_lines" # [win]
  61. - pytest -vv --doctest-modules boltons tests # [not win]
  62. - pip check
  63. about:
  64. home: https://github.com/mahmoud/boltons
  65. dev_url: https://github.com/mahmoud/boltons
  66. doc_url: https://boltons.readthedocs.io/
  67. license: BSD-3-Clause
  68. license_file: LICENSE
  69. license_family: BSD
  70. summary: >
  71. boltons should be builtins. Boltons is a set of over 160 BSD-licensed, pure-Python utilities in the same spirit as--and yet conspicuously missing from--the standard library.
  72. description: |
  73. Boltons is a set of pure-Python utilities in the same spirit as — and yet conspicuously missing from — the standard library, including:
  74. - Atomic file saving, bolted on with fileutils
  75. - A highly-optimized OrderedMultiDict, in dictutils
  76. - Two types of PriorityQueue, in queueutils
  77. - Chunked and windowed iteration, in iterutils
  78. - A full-featured TracebackInfo type, for representing stack traces, in tbutils
  79. - A lightweight UTC timezone available in timeutils.
  80. - Recursive mapping for nested data transforms, with remap
  81. extra:
  82. recipe-maintainers:
  83. - kalefranz
  84. - nicoddemus