meta.yaml 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. # This file created by conda-build 3.22.0
  2. # meta.yaml template originally from:
  3. # /feedstock/recipe, last modified Tue Feb 28 23:58:05 2023
  4. # ------------------------------------------------
  5. package:
  6. name: boltons
  7. version: 23.0.0
  8. source:
  9. fn: boltons-23.0.0.tar.gz
  10. sha256: 9b2998cd9525ed472079c7dd90fbd216a887202e8729d5969d4f33878f0ff668
  11. url: https://github.com/mahmoud/boltons/archive/23.0.0.tar.gz
  12. build:
  13. number: '0'
  14. script: /croot/boltons_1677628692245/_h_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold/bin/python
  15. -m pip install . --no-deps -vv
  16. string: py39h06a4308_0
  17. requirements:
  18. host:
  19. - _libgcc_mutex 0.1 main
  20. - _openmp_mutex 5.1 1_gnu
  21. - ca-certificates 2023.01.10 h06a4308_0
  22. - certifi 2022.12.7 py39h06a4308_0
  23. - ld_impl_linux-64 2.38 h1181459_1
  24. - libffi 3.4.2 h6a678d5_6
  25. - libgcc-ng 11.2.0 h1234567_1
  26. - libgomp 11.2.0 h1234567_1
  27. - libstdcxx-ng 11.2.0 h1234567_1
  28. - ncurses 6.4 h6a678d5_0
  29. - openssl 1.1.1t h7f8727e_0
  30. - pip 22.3.1 py39h06a4308_0
  31. - python 3.9.16 h7a1cb2a_0
  32. - readline 8.2 h5eee18b_0
  33. - setuptools 65.6.3 py39h06a4308_0
  34. - sqlite 3.40.1 h5082296_0
  35. - tk 8.6.12 h1ccaba5_0
  36. - tzdata 2022g h04d1e81_0
  37. - wheel 0.38.4 py39h06a4308_0
  38. - xz 5.2.10 h5eee18b_1
  39. - zlib 1.2.13 h5eee18b_0
  40. run:
  41. - python >=3.9,<3.10.0a0
  42. test:
  43. commands:
  44. - pytest -vv --doctest-modules boltons tests
  45. - pip check
  46. imports:
  47. - boltons
  48. - boltons.cacheutils
  49. - boltons.debugutils
  50. - boltons.dictutils
  51. - boltons.ecoutils
  52. - boltons.fileutils
  53. - boltons.formatutils
  54. - boltons.funcutils
  55. - boltons.gcutils
  56. - boltons.ioutils
  57. - boltons.iterutils
  58. - boltons.jsonutils
  59. - boltons.listutils
  60. - boltons.mathutils
  61. - boltons.mboxutils
  62. - boltons.namedutils
  63. - boltons.pathutils
  64. - boltons.queueutils
  65. - boltons.setutils
  66. - boltons.socketutils
  67. - boltons.statsutils
  68. - boltons.strutils
  69. - boltons.tableutils
  70. - boltons.tbutils
  71. - boltons.timeutils
  72. - boltons.typeutils
  73. - boltons.urlutils
  74. requires:
  75. - pip
  76. - pytest
  77. source_files:
  78. - boltons
  79. - pytest.ini
  80. - tests
  81. about:
  82. description: "Boltons is a set of pure-Python utilities in the same spirit as \u2014\
  83. \ and yet conspicuously missing from \u2014 the standard library, including:\n\
  84. \n - Atomic file saving, bolted on with fileutils\n - A highly-optimized OrderedMultiDict,\
  85. \ in dictutils\n - Two types of PriorityQueue, in queueutils\n - Chunked and\
  86. \ windowed iteration, in iterutils\n - A full-featured TracebackInfo type, for\
  87. \ representing stack traces, in tbutils\n - A lightweight UTC timezone available\
  88. \ in timeutils.\n - Recursive mapping for nested data transforms, with remap\n"
  89. dev_url: https://github.com/mahmoud/boltons
  90. doc_url: https://boltons.readthedocs.io/
  91. home: https://github.com/mahmoud/boltons
  92. license: BSD-3-Clause
  93. license_family: BSD
  94. license_file: LICENSE
  95. summary: 'boltons should be builtins. Boltons is a set of over 160 BSD-licensed,
  96. pure-Python utilities in the same spirit as--and yet conspicuously missing from--the
  97. standard library.
  98. '
  99. extra:
  100. copy_test_source_files: true
  101. final: true
  102. flow_run_id: 92fdb403-e990-4b2b-a38f-3627e5b4abc2
  103. recipe-maintainers:
  104. - kalefranz
  105. - nicoddemus
  106. remote_url: git@github.com:AnacondaRecipes/boltons-feedstock.git
  107. sha: 1d419355e50979b5269329d2635120d45ad58b07